cve.bz

CVE-2022-41910

9.1 criticalEPSS 0.4%

Critical (9.1) in google tensorflow. EPSS 0.4% chance of exploitation in the next 30 days. Fixed in tensorflow 2.10.1, 2.8.4, 2.9.3.

TensorFlow is an open source platform for machine learning. The function MakeGrapplerFunctionItem takes arguments that determine the sizes of inputs and outputs. If the inputs given are greater than or equal to the sizes of the outputs, an out-of-bounds memory read or a crash is triggered. We have patched the issue in GitHub commit a65411a1d69edfb16b25907ffb8f73556ce36bb7. The fix will be included in TensorFlow 2.11.0. We will also cherrypick this commit on TensorFlow 2.8.4, 2.9.3, and 2.10.1.

Severity

CVSS 3.1

9.1 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
EPSS
0.4% chance of exploitation in the next 30 days; higher than 38% of CVEs (scores of 2026-10-31)
CWE
CWE-125
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-frqp-wp83-qggvPyPItensorflow<2.8.42.8.4
GHSA-frqp-wp83-qggvPyPItensorflow>=2.9.0 <2.9.32.9.3
GHSA-frqp-wp83-qggvPyPItensorflow>=2.10.0 <2.10.12.10.1
GHSA-frqp-wp83-qggvPyPItensorflow-cpu<2.8.42.8.4
GHSA-frqp-wp83-qggvPyPItensorflow-gpu<2.8.42.8.4
GHSA-frqp-wp83-qggvPyPItensorflow-cpu>=2.9.0 <2.9.32.9.3
GHSA-frqp-wp83-qggvPyPItensorflow-gpu>=2.9.0 <2.9.32.9.3
GHSA-frqp-wp83-qggvPyPItensorflow-cpu>=2.10.0 <2.10.12.10.1
GHSA-frqp-wp83-qggvPyPItensorflow-gpu>=2.10.0 <2.10.12.10.1
PYSEC-2026-3178PyPItensorflow<2.8.4
>=2.9.0 <2.9.3
>=2.10.0 <2.10.1
2.8.4, 2.9.3, 2.10.1
PYSEC-2026-3323PyPItensorflow-cpu<2.8.4
>=2.9.0 <2.9.3
>=2.10.0 <2.10.1
2.8.4, 2.9.3, 2.10.1
PYSEC-2026-992PyPItensorflow-gpu<2.8.4
>=2.9.0 <2.9.3
>=2.10.0 <2.10.1
2.8.4, 2.9.3, 2.10.1

References

Check your stackJSON