{"cve":"CVE-2022-41910","nvd":{"published":"2022-12-06T22:15:10.587","modified":"2026-06-17T05:04:02.730","status":"Modified","description":"TensorFlow is an open source platform for machine learning. The function MakeGrapplerFunctionItem takes arguments that determine the sizes of inputs and outputs. If the inputs given are greater than or equal to the sizes of the outputs, an out-of-bounds memory read or a crash is triggered. We have patched the issue in GitHub commit a65411a1d69edfb16b25907ffb8f73556ce36bb7. The fix will be included in TensorFlow 2.11.0. We will also cherrypick this commit on TensorFlow 2.8.4, 2.9.3, and 2.10.1.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H","score":9.1},"cwes":["CWE-125"],"references":["https://github.com/tensorflow/tensorflow/blob/master/tensorflow/core/grappler/utils/functions.cc#L221","https://github.com/tensorflow/tensorflow/commit/a65411a1d69edfb16b25907ffb8f73556ce36bb7","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-frqp-wp83-qggv","https://github.com/tensorflow/tensorflow/blob/master/tensorflow/core/grappler/utils/functions.cc#L221","https://github.com/tensorflow/tensorflow/commit/a65411a1d69edfb16b25907ffb8f73556ce36bb7"],"products":["google:tensorflow"],"source":"nvd","synced_at":"2026-10-19T21:37:28.463369388+00:00"},"epss":{"cve":"CVE-2022-41910","score":0.00439,"percentile":0.38145,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-frqp-wp83-qggv","url":"https://osv.dev/vulnerability/GHSA-frqp-wp83-qggv","summary":"Heap overflow in `QuantizeAndDequantizeV2`","modified":"2026-07-13T16:43:03.562106042Z","packages":[{"ecosystem":"PyPI","name":"tensorflow","purl":"pkg:pypi/tensorflow","ranges":["<2.8.4"],"fixed":["2.8.4"]},{"ecosystem":"PyPI","name":"tensorflow","purl":"pkg:pypi/tensorflow","ranges":[">=2.9.0 <2.9.3"],"fixed":["2.9.3"]},{"ecosystem":"PyPI","name":"tensorflow","purl":"pkg:pypi/tensorflow","ranges":[">=2.10.0 <2.10.1"],"fixed":["2.10.1"]},{"ecosystem":"PyPI","name":"tensorflow-cpu","purl":"pkg:pypi/tensorflow-cpu","ranges":["<2.8.4"],"fixed":["2.8.4"]},{"ecosystem":"PyPI","name":"tensorflow-gpu","purl":"pkg:pypi/tensorflow-gpu","ranges":["<2.8.4"],"fixed":["2.8.4"]},{"ecosystem":"PyPI","name":"tensorflow-cpu","purl":"pkg:pypi/tensorflow-cpu","ranges":[">=2.9.0 <2.9.3"],"fixed":["2.9.3"]},{"ecosystem":"PyPI","name":"tensorflow-gpu","purl":"pkg:pypi/tensorflow-gpu","ranges":[">=2.9.0 <2.9.3"],"fixed":["2.9.3"]},{"ecosystem":"PyPI","name":"tensorflow-cpu","purl":"pkg:pypi/tensorflow-cpu","ranges":[">=2.10.0 <2.10.1"],"fixed":["2.10.1"]},{"ecosystem":"PyPI","name":"tensorflow-gpu","purl":"pkg:pypi/tensorflow-gpu","ranges":[">=2.10.0 <2.10.1"],"fixed":["2.10.1"]}]},{"id":"PYSEC-2026-3178","url":"https://osv.dev/vulnerability/PYSEC-2026-3178","summary":"Heap overflow in `QuantizeAndDequantizeV2`","modified":"2026-07-13T16:43:03.562106042Z","packages":[{"ecosystem":"PyPI","name":"tensorflow","purl":"pkg:pypi/tensorflow","ranges":["<2.8.4",">=2.9.0 <2.9.3",">=2.10.0 <2.10.1"],"fixed":["2.8.4","2.9.3","2.10.1"]}]},{"id":"PYSEC-2026-3323","url":"https://osv.dev/vulnerability/PYSEC-2026-3323","summary":"Heap overflow in `QuantizeAndDequantizeV2`","modified":"2026-07-13T16:43:03.562106042Z","packages":[{"ecosystem":"PyPI","name":"tensorflow-cpu","purl":"pkg:pypi/tensorflow-cpu","ranges":["<2.8.4",">=2.9.0 <2.9.3",">=2.10.0 <2.10.1"],"fixed":["2.8.4","2.9.3","2.10.1"]}]},{"id":"PYSEC-2026-992","url":"https://osv.dev/vulnerability/PYSEC-2026-992","summary":"Heap overflow in `QuantizeAndDequantizeV2`","modified":"2026-07-13T16:43:03.562106042Z","packages":[{"ecosystem":"PyPI","name":"tensorflow-gpu","purl":"pkg:pypi/tensorflow-gpu","ranges":["<2.8.4",">=2.9.0 <2.9.3",">=2.10.0 <2.10.1"],"fixed":["2.8.4","2.9.3","2.10.1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}