cve.bz

CVE-2022-41909

7.5 highEPSS 0.5%

High (7.5) in google tensorflow. EPSS 0.5% chance of exploitation in the next 30 days. Fixed in tensorflow 2.10.1, 2.8.4, 2.9.3.

TensorFlow is an open source platform for machine learning. An input `encoded` that is not a valid `CompositeTensorVariant` tensor will trigger a segfault in `tf.raw_ops.CompositeTensorVariantToComponents`. We have patched the issue in GitHub commits bf594d08d377dc6a3354d9fdb494b32d45f91971 and 660ce5a89eb6766834bdc303d2ab3902aef99d3d. The fix will be included in TensorFlow 2.11. We will also cherrypick this commit on TensorFlow 2.10.1, 2.9.3, and TensorFlow 2.8.4, as these are also affected and still in supported range.

Severity

CVSS 3.1

7.5 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
0.5% chance of exploitation in the next 30 days; higher than 45% of CVEs (scores of 2026-10-31)
CWEs
CWE-476, CWE-20
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-rjx6-v474-2ch9PyPItensorflow<2.8.42.8.4
GHSA-rjx6-v474-2ch9PyPItensorflow>=2.9.0 <2.9.32.9.3
GHSA-rjx6-v474-2ch9PyPItensorflow>=2.10.0 <2.10.12.10.1
GHSA-rjx6-v474-2ch9PyPItensorflow-cpu<2.8.42.8.4
GHSA-rjx6-v474-2ch9PyPItensorflow-gpu<2.8.42.8.4
GHSA-rjx6-v474-2ch9PyPItensorflow-cpu>=2.9.0 <2.9.32.9.3
GHSA-rjx6-v474-2ch9PyPItensorflow-gpu>=2.9.0 <2.9.32.9.3
GHSA-rjx6-v474-2ch9PyPItensorflow-cpu>=2.10.0 <2.10.12.10.1
GHSA-rjx6-v474-2ch9PyPItensorflow-gpu>=2.10.0 <2.10.12.10.1
PYSEC-2026-1034PyPItensorflow-gpu<2.8.4
>=2.9.0 <2.9.3
>=2.10.0 <2.10.1
2.8.4, 2.9.3, 2.10.1
PYSEC-2026-3238PyPItensorflow<2.8.4
>=2.9.0 <2.9.3
>=2.10.0 <2.10.1
2.8.4, 2.9.3, 2.10.1
PYSEC-2026-3368PyPItensorflow-cpu<2.8.4
>=2.9.0 <2.9.3
>=2.10.0 <2.10.1
2.8.4, 2.9.3, 2.10.1

References

Check your stackJSON