cve.bz

CVE-2022-39322

9.8 criticalEPSS 1.5%

Critical (9.8) in keystonejs keystone. EPSS 1.5% chance of exploitation in the next 30 days. Fixed in @keystone-6/core 2.3.1.

@keystone-6/core is a core package for Keystone 6, a content management system for Node.js. Starting with version 2.2.0 and prior to version 2.3.1, users who expected their `multiselect` fields to use the field-level access control - if configured - are vulnerable to their field-level access control not being used. List-level access control is not affected. Field-level access control for fields other than `multiselect` are not affected. Version 2.3.1 contains a fix for this issue. As a workaround, stop using the `multiselect` field.

Severity

CVSS 3.1

9.8 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
1.5% chance of exploitation in the next 30 days; higher than 73% of CVEs (scores of 2026-10-31)
CWEs
CWE-863, CWE-285
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-6mhr-52mv-6v6fnpm@keystone-6/core>=2.2.0 <2.3.12.3.1

References

Check your stackJSON