cve.bz

CVE-2022-36013

7.5 highEPSS 0.7%

High (7.5) in google tensorflow. EPSS 0.7% chance of exploitation in the next 30 days. Fixed in tensorflow 2.7.2, 2.8.1, 2.9.1.

TensorFlow is an open source platform for machine learning. When `mlir::tfg::GraphDefImporter::ConvertNodeDef` tries to convert NodeDefs without an op name, it crashes. We have patched the issue in GitHub commit a0f0b9a21c9270930457095092f558fbad4c03e5. The fix will be included in TensorFlow 2.10.0. We will also cherrypick this commit on TensorFlow 2.9.1, TensorFlow 2.8.1, and TensorFlow 2.7.2, as these are also affected and still in supported range. There are no known workarounds for this issue.

Severity

CVSS 3.1

7.5 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
0.7% chance of exploitation in the next 30 days; higher than 53% of CVEs (scores of 2026-10-31)
CWE
CWE-476
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-828c-5j5q-vrjqPyPItensorflow<2.7.22.7.2
GHSA-828c-5j5q-vrjqPyPItensorflow>=2.8.0 <2.8.12.8.1
GHSA-828c-5j5q-vrjqPyPItensorflow>=2.9.0 <2.9.12.9.1
GHSA-828c-5j5q-vrjqPyPItensorflow-cpu<2.7.22.7.2
GHSA-828c-5j5q-vrjqPyPItensorflow-cpu>=2.8.0 <2.8.12.8.1
GHSA-828c-5j5q-vrjqPyPItensorflow-cpu>=2.9.0 <2.9.12.9.1
GHSA-828c-5j5q-vrjqPyPItensorflow-gpu<2.7.22.7.2
GHSA-828c-5j5q-vrjqPyPItensorflow-gpu>=2.8.0 <2.8.12.8.1
GHSA-828c-5j5q-vrjqPyPItensorflow-gpu>=2.9.0 <2.9.12.9.1
PYSEC-2026-3132PyPItensorflow<2.7.2
>=2.8.0 <2.8.1
>=2.9.0 <2.9.1
2.7.2, 2.8.1, 2.9.1
PYSEC-2026-3295PyPItensorflow-cpu<2.7.2
>=2.8.0 <2.8.1
>=2.9.0 <2.9.1
2.7.2, 2.8.1, 2.9.1
PYSEC-2026-968PyPItensorflow-gpu<2.7.2
>=2.8.0 <2.8.1
>=2.9.0 <2.9.1
2.7.2, 2.8.1, 2.9.1

References

Check your stackJSON