cve.bz

CVE-2022-36000

7.5 highEPSS 0.5%

High (7.5) in google tensorflow. EPSS 0.5% chance of exploitation in the next 30 days. Fixed in tensorflow 2.7.2, 2.8.1, 2.9.1.

TensorFlow is an open source platform for machine learning. When `mlir::tfg::ConvertGenericFunctionToFunctionDef` is given empty function attributes, it gives a null dereference. We have patched the issue in GitHub commit aed36912609fc07229b4d0a7b44f3f48efc00fd0. The fix will be included in TensorFlow 2.10.0. We will also cherrypick this commit on TensorFlow 2.9.1, TensorFlow 2.8.1, and TensorFlow 2.7.2, as these are also affected and still in supported range. There are no known workarounds for this issue.

Severity

CVSS 3.1

7.5 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
0.5% chance of exploitation in the next 30 days; higher than 41% of CVEs (scores of 2026-10-31)
CWE
CWE-476
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-fqxc-pvf8-2w9vPyPItensorflow<2.7.22.7.2
GHSA-fqxc-pvf8-2w9vPyPItensorflow>=2.8.0 <2.8.12.8.1
GHSA-fqxc-pvf8-2w9vPyPItensorflow>=2.9.0 <2.9.12.9.1
GHSA-fqxc-pvf8-2w9vPyPItensorflow-cpu<2.7.22.7.2
GHSA-fqxc-pvf8-2w9vPyPItensorflow-cpu>=2.8.0 <2.8.12.8.1
GHSA-fqxc-pvf8-2w9vPyPItensorflow-cpu>=2.9.0 <2.9.12.9.1
GHSA-fqxc-pvf8-2w9vPyPItensorflow-gpu<2.7.22.7.2
GHSA-fqxc-pvf8-2w9vPyPItensorflow-gpu>=2.8.0 <2.8.12.8.1
GHSA-fqxc-pvf8-2w9vPyPItensorflow-gpu>=2.9.0 <2.9.12.9.1
PYSEC-2026-3177PyPItensorflow<2.7.2
>=2.8.0 <2.8.1
>=2.9.0 <2.9.1
2.7.2, 2.8.1, 2.9.1
PYSEC-2026-3322PyPItensorflow-cpu<2.7.2
>=2.8.0 <2.8.1
>=2.9.0 <2.9.1
2.7.2, 2.8.1, 2.9.1
PYSEC-2026-991PyPItensorflow-gpu<2.7.2
>=2.8.0 <2.8.1
>=2.9.0 <2.9.1
2.7.2, 2.8.1, 2.9.1

References

Check your stackJSON