cve.bz

CVE-2022-35991

7.5 highEPSS 0.5%

High (7.5) in google tensorflow. EPSS 0.5% chance of exploitation in the next 30 days. Fixed in tensorflow 2.7.2, 2.8.1, 2.9.1.

TensorFlow is an open source platform for machine learning. When `TensorListScatter` and `TensorListScatterV2` receive an `element_shape` of a rank greater than one, they give a `CHECK` fail that can trigger a denial of service attack. We have patched the issue in GitHub commit bb03fdf4aae944ab2e4b35c7daa051068a8b7f61. The fix will be included in TensorFlow 2.10.0. We will also cherrypick this commit on TensorFlow 2.9.1, TensorFlow 2.8.1, and TensorFlow 2.7.2, as these are also affected and still in supported range. There are no known workarounds for this issue.

Severity

CVSS 3.1

7.5 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
0.5% chance of exploitation in the next 30 days; higher than 44% of CVEs (scores of 2026-10-31)
CWE
CWE-617
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-vm7x-4qhj-rrcqPyPItensorflow<2.7.22.7.2
GHSA-vm7x-4qhj-rrcqPyPItensorflow>=2.8.0 <2.8.12.8.1
GHSA-vm7x-4qhj-rrcqPyPItensorflow>=2.9.0 <2.9.12.9.1
GHSA-vm7x-4qhj-rrcqPyPItensorflow-cpu<2.7.22.7.2
GHSA-vm7x-4qhj-rrcqPyPItensorflow-cpu>=2.8.0 <2.8.12.8.1
GHSA-vm7x-4qhj-rrcqPyPItensorflow-cpu>=2.9.0 <2.9.12.9.1
GHSA-vm7x-4qhj-rrcqPyPItensorflow-gpu<2.7.22.7.2
GHSA-vm7x-4qhj-rrcqPyPItensorflow-gpu>=2.8.0 <2.8.12.8.1
GHSA-vm7x-4qhj-rrcqPyPItensorflow-gpu>=2.9.0 <2.9.12.9.1
PYSEC-2026-1040PyPItensorflow-gpu<2.7.2
>=2.8.0 <2.8.1
>=2.9.0 <2.9.1
2.7.2, 2.8.1, 2.9.1
PYSEC-2026-3248PyPItensorflow<2.7.2
>=2.8.0 <2.8.1
>=2.9.0 <2.9.1
2.7.2, 2.8.1, 2.9.1
PYSEC-2026-3374PyPItensorflow-cpu<2.7.2
>=2.8.0 <2.8.1
>=2.9.0 <2.9.1
2.7.2, 2.8.1, 2.9.1

References

Check your stackJSON