{"cve":"CVE-2022-35991","nvd":{"published":"2022-09-16T23:15:10.100","modified":"2026-06-17T04:52:41.510","status":"Modified","description":"TensorFlow is an open source platform for machine learning. When `TensorListScatter` and `TensorListScatterV2` receive an `element_shape` of a rank greater than one, they give a `CHECK` fail that can trigger a denial of service attack. We have patched the issue in GitHub commit bb03fdf4aae944ab2e4b35c7daa051068a8b7f61. The fix will be included in TensorFlow 2.10.0. We will also cherrypick this commit on TensorFlow 2.9.1, TensorFlow 2.8.1, and TensorFlow 2.7.2, as these are also affected and still in supported range. There are no known workarounds for this issue.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","score":7.5},"cwes":["CWE-617"],"references":["https://github.com/tensorflow/tensorflow/commit/bb03fdf4aae944ab2e4b35c7daa051068a8b7f61","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-vm7x-4qhj-rrcq","https://github.com/tensorflow/tensorflow/commit/bb03fdf4aae944ab2e4b35c7daa051068a8b7f61","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-vm7x-4qhj-rrcq"],"products":["google:tensorflow"],"source":"nvd","synced_at":"2026-10-19T21:35:14.992143698+00:00"},"epss":{"cve":"CVE-2022-35991","score":0.00531,"percentile":0.44916,"date":"2026-11-01"},"kev":null,"osv":[{"id":"GHSA-vm7x-4qhj-rrcq","url":"https://osv.dev/vulnerability/GHSA-vm7x-4qhj-rrcq","summary":"TensorFlow vulnerable to `CHECK` fail in `TensorListScatter` and `TensorListScatterV2`","modified":"2026-07-13T16:43:37.624150734Z","packages":[{"ecosystem":"PyPI","name":"tensorflow","purl":"pkg:pypi/tensorflow","ranges":["<2.7.2"],"fixed":["2.7.2"]},{"ecosystem":"PyPI","name":"tensorflow","purl":"pkg:pypi/tensorflow","ranges":[">=2.8.0 <2.8.1"],"fixed":["2.8.1"]},{"ecosystem":"PyPI","name":"tensorflow","purl":"pkg:pypi/tensorflow","ranges":[">=2.9.0 <2.9.1"],"fixed":["2.9.1"]},{"ecosystem":"PyPI","name":"tensorflow-cpu","purl":"pkg:pypi/tensorflow-cpu","ranges":["<2.7.2"],"fixed":["2.7.2"]},{"ecosystem":"PyPI","name":"tensorflow-cpu","purl":"pkg:pypi/tensorflow-cpu","ranges":[">=2.8.0 <2.8.1"],"fixed":["2.8.1"]},{"ecosystem":"PyPI","name":"tensorflow-cpu","purl":"pkg:pypi/tensorflow-cpu","ranges":[">=2.9.0 <2.9.1"],"fixed":["2.9.1"]},{"ecosystem":"PyPI","name":"tensorflow-gpu","purl":"pkg:pypi/tensorflow-gpu","ranges":["<2.7.2"],"fixed":["2.7.2"]},{"ecosystem":"PyPI","name":"tensorflow-gpu","purl":"pkg:pypi/tensorflow-gpu","ranges":[">=2.8.0 <2.8.1"],"fixed":["2.8.1"]},{"ecosystem":"PyPI","name":"tensorflow-gpu","purl":"pkg:pypi/tensorflow-gpu","ranges":[">=2.9.0 <2.9.1"],"fixed":["2.9.1"]}]},{"id":"PYSEC-2026-1040","url":"https://osv.dev/vulnerability/PYSEC-2026-1040","summary":"TensorFlow vulnerable to `CHECK` fail in `TensorListScatter` and `TensorListScatterV2`","modified":"2026-07-13T16:43:37.624150734Z","packages":[{"ecosystem":"PyPI","name":"tensorflow-gpu","purl":"pkg:pypi/tensorflow-gpu","ranges":["<2.7.2",">=2.8.0 <2.8.1",">=2.9.0 <2.9.1"],"fixed":["2.7.2","2.8.1","2.9.1"]}]},{"id":"PYSEC-2026-3248","url":"https://osv.dev/vulnerability/PYSEC-2026-3248","summary":"TensorFlow vulnerable to `CHECK` fail in `TensorListScatter` and `TensorListScatterV2`","modified":"2026-07-13T16:43:37.624150734Z","packages":[{"ecosystem":"PyPI","name":"tensorflow","purl":"pkg:pypi/tensorflow","ranges":["<2.7.2",">=2.8.0 <2.8.1",">=2.9.0 <2.9.1"],"fixed":["2.7.2","2.8.1","2.9.1"]}]},{"id":"PYSEC-2026-3374","url":"https://osv.dev/vulnerability/PYSEC-2026-3374","summary":"TensorFlow vulnerable to `CHECK` fail in `TensorListScatter` and `TensorListScatterV2`","modified":"2026-07-13T16:43:37.624150734Z","packages":[{"ecosystem":"PyPI","name":"tensorflow-cpu","purl":"pkg:pypi/tensorflow-cpu","ranges":["<2.7.2",">=2.8.0 <2.8.1",">=2.9.0 <2.9.1"],"fixed":["2.7.2","2.8.1","2.9.1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}