cve.bz

CVE-2022-35965

7.5 highEPSS 0.5%

High (7.5) in google tensorflow. EPSS 0.5% chance of exploitation in the next 30 days. Fixed in tensorflow 2.7.2, 2.8.1, 2.9.1.

TensorFlow is an open source platform for machine learning. If `LowerBound` or `UpperBound` is given an empty`sorted_inputs` input, it results in a `nullptr` dereference, leading to a segfault that can be used to trigger a denial of service attack. We have patched the issue in GitHub commit bce3717eaef4f769019fd18e990464ca4a2efeea. The fix will be included in TensorFlow 2.10.0. We will also cherrypick this commit on TensorFlow 2.9.1, TensorFlow 2.8.1, and TensorFlow 2.7.2, as these are also affected and still in supported range. There are no known workarounds for this issue.

Severity

CVSS 3.1

7.5 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
0.5% chance of exploitation in the next 30 days; higher than 40% of CVEs (scores of 2026-10-31)
CWE
CWE-476
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-qxpx-j395-pw36PyPItensorflow<2.7.22.7.2
GHSA-qxpx-j395-pw36PyPItensorflow>=2.8.0 <2.8.12.8.1
GHSA-qxpx-j395-pw36PyPItensorflow>=2.9.0 <2.9.12.9.1
GHSA-qxpx-j395-pw36PyPItensorflow-cpu<2.7.22.7.2
GHSA-qxpx-j395-pw36PyPItensorflow-cpu>=2.8.0 <2.8.12.8.1
GHSA-qxpx-j395-pw36PyPItensorflow-cpu>=2.9.0 <2.9.12.9.1
GHSA-qxpx-j395-pw36PyPItensorflow-gpu<2.7.22.7.2
GHSA-qxpx-j395-pw36PyPItensorflow-gpu>=2.8.0 <2.8.12.8.1
GHSA-qxpx-j395-pw36PyPItensorflow-gpu>=2.9.0 <2.9.12.9.1
PYSEC-2026-1030PyPItensorflow-gpu<2.7.2
>=2.8.0 <2.8.1
>=2.9.0 <2.9.1
2.7.2, 2.8.1, 2.9.1
PYSEC-2026-3233PyPItensorflow<2.7.2
>=2.8.0 <2.8.1
>=2.9.0 <2.9.1
2.7.2, 2.8.1, 2.9.1
PYSEC-2026-3363PyPItensorflow-cpu<2.7.2
>=2.8.0 <2.8.1
>=2.9.0 <2.9.1
2.7.2, 2.8.1, 2.9.1

References

Check your stackJSON