cve.bz

CVE-2022-35934

7.5 highEPSS 0.5%

High (7.5) in google tensorflow. EPSS 0.5% chance of exploitation in the next 30 days. Fixed in tensorflow 2.7.2, 2.8.1, 2.9.1.

TensorFlow is an open source platform for machine learning. The implementation of tf.reshape op in TensorFlow is vulnerable to a denial of service via CHECK-failure (assertion failure) caused by overflowing the number of elements in a tensor. This issue has been patched in GitHub commit 61f0f9b94df8c0411f0ad0ecc2fec2d3f3c33555. The fix will be included in TensorFlow 2.10.0. We will also cherrypick this commit on TensorFlow 2.9.1, TensorFlow 2.8.1, and TensorFlow 2.7.2, as these are also affected and still in supported range. There are no known workarounds for this issue.

Severity

CVSS 3.1

7.5 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
0.5% chance of exploitation in the next 30 days; higher than 41% of CVEs (scores of 2026-10-31)
CWE
CWE-617
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-f4w6-h4f5-wx45PyPItensorflow<2.7.22.7.2
GHSA-f4w6-h4f5-wx45PyPItensorflow>=2.8.0 <2.8.12.8.1
GHSA-f4w6-h4f5-wx45PyPItensorflow>=2.9.0 <2.9.12.9.1
GHSA-f4w6-h4f5-wx45PyPItensorflow-cpu<2.7.22.7.2
GHSA-f4w6-h4f5-wx45PyPItensorflow-cpu>=2.8.0 <2.8.12.8.1
GHSA-f4w6-h4f5-wx45PyPItensorflow-cpu>=2.9.0 <2.9.12.9.1
GHSA-f4w6-h4f5-wx45PyPItensorflow-gpu<2.7.22.7.2
GHSA-f4w6-h4f5-wx45PyPItensorflow-gpu>=2.8.0 <2.8.12.8.1
GHSA-f4w6-h4f5-wx45PyPItensorflow-gpu>=2.9.0 <2.9.12.9.1
PYSEC-2026-3168PyPItensorflow<2.7.2
>=2.8.0 <2.8.1
>=2.9.0 <2.9.1
2.7.2, 2.8.1, 2.9.1
PYSEC-2026-3316PyPItensorflow-cpu<2.7.2
>=2.8.0 <2.8.1
>=2.9.0 <2.9.1
2.7.2, 2.8.1, 2.9.1
PYSEC-2026-987PyPItensorflow-gpu<2.7.2
>=2.8.0 <2.8.1
>=2.9.0 <2.9.1
2.7.2, 2.8.1, 2.9.1

References

Check your stackJSON