{"cve":"CVE-2022-35934","nvd":{"published":"2022-09-16T20:15:09.980","modified":"2026-06-17T04:52:33.257","status":"Modified","description":"TensorFlow is an open source platform for machine learning. The implementation of tf.reshape op in TensorFlow is vulnerable to a denial of service via CHECK-failure (assertion failure) caused by overflowing the number of elements in a tensor. This issue has been patched in GitHub commit 61f0f9b94df8c0411f0ad0ecc2fec2d3f3c33555. The fix will be included in TensorFlow 2.10.0. We will also cherrypick this commit on TensorFlow 2.9.1, TensorFlow 2.8.1, and TensorFlow 2.7.2, as these are also affected and still in supported range. There are no known workarounds for this issue.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","score":7.5},"cwes":["CWE-617"],"references":["https://github.com/tensorflow/tensorflow/commit/61f0f9b94df8c0411f0ad0ecc2fec2d3f3c33555","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-f4w6-h4f5-wx45","https://github.com/tensorflow/tensorflow/commit/61f0f9b94df8c0411f0ad0ecc2fec2d3f3c33555","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-f4w6-h4f5-wx45"],"products":["google:tensorflow"],"source":"nvd","synced_at":"2026-10-19T21:35:14.992143698+00:00"},"epss":{"cve":"CVE-2022-35934","score":0.00478,"percentile":0.41251,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-f4w6-h4f5-wx45","url":"https://osv.dev/vulnerability/GHSA-f4w6-h4f5-wx45","summary":"TensorFlow vulnerable to `CHECK` failure in tf.reshape via overflows","modified":"2026-07-13T16:43:52.767816384Z","packages":[{"ecosystem":"PyPI","name":"tensorflow","purl":"pkg:pypi/tensorflow","ranges":["<2.7.2"],"fixed":["2.7.2"]},{"ecosystem":"PyPI","name":"tensorflow","purl":"pkg:pypi/tensorflow","ranges":[">=2.8.0 <2.8.1"],"fixed":["2.8.1"]},{"ecosystem":"PyPI","name":"tensorflow","purl":"pkg:pypi/tensorflow","ranges":[">=2.9.0 <2.9.1"],"fixed":["2.9.1"]},{"ecosystem":"PyPI","name":"tensorflow-cpu","purl":"pkg:pypi/tensorflow-cpu","ranges":["<2.7.2"],"fixed":["2.7.2"]},{"ecosystem":"PyPI","name":"tensorflow-cpu","purl":"pkg:pypi/tensorflow-cpu","ranges":[">=2.8.0 <2.8.1"],"fixed":["2.8.1"]},{"ecosystem":"PyPI","name":"tensorflow-cpu","purl":"pkg:pypi/tensorflow-cpu","ranges":[">=2.9.0 <2.9.1"],"fixed":["2.9.1"]},{"ecosystem":"PyPI","name":"tensorflow-gpu","purl":"pkg:pypi/tensorflow-gpu","ranges":["<2.7.2"],"fixed":["2.7.2"]},{"ecosystem":"PyPI","name":"tensorflow-gpu","purl":"pkg:pypi/tensorflow-gpu","ranges":[">=2.8.0 <2.8.1"],"fixed":["2.8.1"]},{"ecosystem":"PyPI","name":"tensorflow-gpu","purl":"pkg:pypi/tensorflow-gpu","ranges":[">=2.9.0 <2.9.1"],"fixed":["2.9.1"]}]},{"id":"PYSEC-2026-3168","url":"https://osv.dev/vulnerability/PYSEC-2026-3168","summary":"TensorFlow vulnerable to `CHECK` failure in tf.reshape via overflows","modified":"2026-07-13T16:43:52.767816384Z","packages":[{"ecosystem":"PyPI","name":"tensorflow","purl":"pkg:pypi/tensorflow","ranges":["<2.7.2",">=2.8.0 <2.8.1",">=2.9.0 <2.9.1"],"fixed":["2.7.2","2.8.1","2.9.1"]}]},{"id":"PYSEC-2026-3316","url":"https://osv.dev/vulnerability/PYSEC-2026-3316","summary":"TensorFlow vulnerable to `CHECK` failure in tf.reshape via overflows","modified":"2026-07-13T16:43:52.767816384Z","packages":[{"ecosystem":"PyPI","name":"tensorflow-cpu","purl":"pkg:pypi/tensorflow-cpu","ranges":["<2.7.2",">=2.8.0 <2.8.1",">=2.9.0 <2.9.1"],"fixed":["2.7.2","2.8.1","2.9.1"]}]},{"id":"PYSEC-2026-987","url":"https://osv.dev/vulnerability/PYSEC-2026-987","summary":"TensorFlow vulnerable to `CHECK` failure in tf.reshape via overflows","modified":"2026-07-13T16:43:52.767816384Z","packages":[{"ecosystem":"PyPI","name":"tensorflow-gpu","purl":"pkg:pypi/tensorflow-gpu","ranges":["<2.7.2",">=2.8.0 <2.8.1",">=2.9.0 <2.9.1"],"fixed":["2.7.2","2.8.1","2.9.1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}