cve.bz

CVE-2022-31121

7.5 highEPSS 2.1%

High (7.5) in hyperledger fabric. EPSS 2.1% chance of exploitation in the next 30 days. Fixed in github.com/hyperledger/fabric 2.2.7, 2.4.5.

Hyperledger Fabric is a permissioned distributed ledger framework. In affected versions if a consensus client sends a malformed consensus request to an orderer it may crash the orderer node. A fix has been added in commit 0f1835949 which checks for missing consensus messages and returns an error to the consensus client should the message be missing. Users are advised to upgrade to versions 2.2.7 or v2.4.5. There are no known workarounds for this issue.

Severity

CVSS 3.1

7.5 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
2.1% chance of exploitation in the next 30 days; higher than 81% of CVEs (scores of 2026-10-31)
CWE
CWE-20
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-72x4-cq6r-jp4pGogithub.com/hyperledger/fabric<2.2.72.2.7
GHSA-72x4-cq6r-jp4pGogithub.com/hyperledger/fabric>=2.3.0 <2.4.52.4.5

References

Check your stackJSON