{"cve":"CVE-2022-31121","nvd":{"published":"2022-07-07T18:15:09.517","modified":"2026-06-17T04:44:50.830","status":"Modified","description":"Hyperledger Fabric is a permissioned distributed ledger framework. In affected versions if a consensus client sends a malformed consensus request to an orderer it may crash the orderer node. A fix has been added in commit 0f1835949 which checks for missing consensus messages and returns an error to the consensus client should the message be missing. Users are advised to upgrade to versions 2.2.7 or v2.4.5. There are no known workarounds for this issue.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","score":7.5},"cwes":["CWE-20"],"references":["https://github.com/hyperledger/fabric/commit/0f18359493bcbd5f9f9d1a9b05adabfe5da23b06","https://github.com/hyperledger/fabric/releases/tag/v2.2.7","https://github.com/hyperledger/fabric/releases/tag/v2.4.5","https://github.com/hyperledger/fabric/security/advisories/GHSA-72x4-cq6r-jp4p","https://github.com/hyperledger/fabric/commit/0f18359493bcbd5f9f9d1a9b05adabfe5da23b06"],"products":["hyperledger:fabric"],"source":"nvd","synced_at":"2026-10-19T21:33:44.859608815+00:00"},"epss":{"cve":"CVE-2022-31121","score":0.02086,"percentile":0.81574,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-72x4-cq6r-jp4p","url":"https://osv.dev/vulnerability/GHSA-72x4-cq6r-jp4p","summary":"Hyperledger Fabric vulnerable to Improper Input Validation in orderer/common/cluster consensus request","modified":"2024-07-18T20:11:50.393825Z","packages":[{"ecosystem":"Go","name":"github.com/hyperledger/fabric","purl":"pkg:golang/github.com/hyperledger/fabric","ranges":["<2.2.7"],"fixed":["2.2.7"]},{"ecosystem":"Go","name":"github.com/hyperledger/fabric","purl":"pkg:golang/github.com/hyperledger/fabric","ranges":[">=2.3.0 <2.4.5"],"fixed":["2.4.5"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}