cve.bz

CVE-2022-31076

5.7 mediumEPSS 0.6%

Medium (5.7) in linuxfoundation kubeedge. EPSS 0.6% chance of exploitation in the next 30 days. Fixed in github.com/kubeedge/kubeedge 1.10.1, 1.9.3.

KubeEdge is built upon Kubernetes and extends native containerized application orchestration and device management to hosts at the Edge. In affected versions a malicious message can crash CloudCore by triggering a nil-pointer dereference in the UDS Server. Since the UDS Server only communicates with the CSI Driver on the cloud side, the attack is limited to the local host network. As such, an attacker would already need to be an authenticated user of the Cloud. Additionally it will be affected only when users turn on the unixsocket switch in the config file cloudcore.yaml. This bug has been fixed in Kubeedge 1.11.0, 1.10.1, and 1.9.3. Users should update to these versions to resolve the issue. Users unable to upgrade should sisable the unixsocket switch of CloudHub in the config file cloudcore.yaml.

Severity

CVSS 3.1

5.7 medium
CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
0.6% chance of exploitation in the next 30 days; higher than 49% of CVEs (scores of 2026-10-31)
CWE
CWE-476
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-8f4f-v9x5-cg6jGogithub.com/kubeedge/kubeedge>=1.10.0 <1.10.11.10.1
GHSA-8f4f-v9x5-cg6jGogithub.com/kubeedge/kubeedge<1.9.31.9.3
GO-2022-0500Gogithub.com/kubeedge/kubeedge<1.9.3
>=1.10.0 <1.10.1
1.9.3, 1.10.1

References

Check your stackJSON