cve.bz

CVE-2022-31042

7.5 highEPSS 2.0%

High (7.5). EPSS 2.0% chance of exploitation in the next 30 days. Fixed in guzzlehttp/guzzle 6.5.7, 7.4.4.

Guzzle is an open source PHP HTTP client. In affected versions the `Cookie` headers on requests are sensitive information. On making a request using the `https` scheme to a server which responds with a redirect to a URI with the `http` scheme, or on making a request to a server which responds with a redirect to a a URI to a different host, we should not forward the `Cookie` header on. Prior to this fix, only cookies that were managed by our cookie middleware would be safely removed, and any `Cookie` header manually added to the initial request would not be stripped. We now always strip it, and allow the cookie middleware to re-add any cookies that it deems should be there. Affected Guzzle 7 users should upgrade to Guzzle 7.4.4 as soon as possible. Affected users using any earlier series of Guzzle should upgrade to Guzzle 6.5.7 or 7.4.4. Users unable to upgrade may consider an alternative approach to use your own redirect middleware, rather than ours. If you do not require or expect redirects to be followed, one should simply disable redirects all together.

Severity

CVSS 3.1

7.5 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
2.0% chance of exploitation in the next 30 days; higher than 80% of CVEs (scores of 2026-10-31)
CWEs
CWE-212, CWE-200
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-f2wf-25xc-69c9Packagistguzzlehttp/guzzle>=4.0.0 <6.5.76.5.7
GHSA-f2wf-25xc-69c9Packagistguzzlehttp/guzzle>=7.0.0 <7.4.47.4.4
GHSA-w248-ffj2-4v5qPackagistguzzlehttp/guzzle>=4.0.0 <6.5.76.5.7
GHSA-w248-ffj2-4v5qPackagistguzzlehttp/guzzle>=7.0.0 <7.4.47.4.4

References

Check your stackJSON