{"cve":"CVE-2022-31042","nvd":{"published":"2022-06-10T00:15:07.690","modified":"2026-06-17T04:44:40.300","status":"Modified","description":"Guzzle is an open source PHP HTTP client. In affected versions the `Cookie` headers on requests are sensitive information. On making a request using the `https` scheme to a server which responds with a redirect to a URI with the `http` scheme, or on making a request to a server which responds with a redirect to a a URI to a different host, we should not forward the `Cookie` header on. Prior to this fix, only cookies that were managed by our cookie middleware would be safely removed, and any `Cookie` header manually added to the initial request would not be stripped. We now always strip it, and allow the cookie middleware to re-add any cookies that it deems should be there. Affected Guzzle 7 users should upgrade to Guzzle 7.4.4 as soon as possible. Affected users using any earlier series of Guzzle should upgrade to Guzzle 6.5.7 or 7.4.4. Users unable to upgrade may consider an alternative approach to use your own redirect middleware, rather than ours. If you do not require or expect redirects to be followed, one should simply disable redirects all together.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","score":7.5},"cwes":["CWE-212","CWE-200"],"references":["https://github.com/guzzle/guzzle/commit/e3ff079b22820c2029d4c2a87796b6a0b8716ad8","https://github.com/guzzle/guzzle/security/advisories/GHSA-f2wf-25xc-69c9","https://www.debian.org/security/2022/dsa-5246","https://www.drupal.org/sa-core-2022-011","https://www.rfc-editor.org/rfc/rfc9110.html#name-redirection-3xx"],"products":["debian:debian_linux","drupal:drupal","guzzlephp:guzzle"],"source":"nvd","synced_at":"2026-10-19T21:32:39.174919249+00:00"},"epss":{"cve":"CVE-2022-31042","score":0.01992,"percentile":0.80678,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-f2wf-25xc-69c9","url":"https://osv.dev/vulnerability/GHSA-f2wf-25xc-69c9","summary":"Failure to strip the Cookie header on change in host or HTTP downgrade","modified":"2025-12-10T23:40:57.755467Z","packages":[{"ecosystem":"Packagist","name":"guzzlehttp/guzzle","purl":"pkg:composer/guzzlehttp/guzzle","ranges":[">=4.0.0 <6.5.7"],"fixed":["6.5.7"]},{"ecosystem":"Packagist","name":"guzzlehttp/guzzle","purl":"pkg:composer/guzzlehttp/guzzle","ranges":[">=7.0.0 <7.4.4"],"fixed":["7.4.4"]}]},{"id":"GHSA-w248-ffj2-4v5q","url":"https://osv.dev/vulnerability/GHSA-w248-ffj2-4v5q","summary":"Fix failure to strip Authorization header on HTTP downgrade","modified":"2025-12-10T23:40:57.755467Z","packages":[{"ecosystem":"Packagist","name":"guzzlehttp/guzzle","purl":"pkg:composer/guzzlehttp/guzzle","ranges":[">=4.0.0 <6.5.7"],"fixed":["6.5.7"]},{"ecosystem":"Packagist","name":"guzzlehttp/guzzle","purl":"pkg:composer/guzzlehttp/guzzle","ranges":[">=7.0.0 <7.4.4"],"fixed":["7.4.4"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}