cve.bz

CVE-2022-31020

8.8 highEPSS 2.3%

High (8.8) in linuxfoundation indy-node. EPSS 2.3% chance of exploitation in the next 30 days. Fixed in indy-node 1.12.5rc1.

Indy Node is the server portion of a distributed ledger purpose-built for decentralized identity. In versions 1.12.4 and prior, the `pool-upgrade` request handler in Indy-Node allows an improperly authenticated attacker to remotely execute code on nodes within the network. The `pool-upgrade` request handler in Indy-Node 1.12.5 has been updated to properly authenticate pool-upgrade transactions before any processing is performed by the request handler. The transactions are further sanitized to prevent remote code execution. As a workaround, endorsers should not create DIDs for untrusted users. A vulnerable ledger should configure `auth_rules` to prevent new DIDs from being written to the ledger until the network can be upgraded.

Severity

CVSS 3.1

8.8 high
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
2.3% chance of exploitation in the next 30 days; higher than 83% of CVEs (scores of 2026-10-31)
CWEs
CWE-20, CWE-287
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-r6v9-p59m-gj2pPyPIindy-node<1.12.5rc11.12.5rc1
PYSEC-2022-265PyPIindy-node<1.12.5rc11.12.5rc1

References

Check your stackJSON