{"cve":"CVE-2022-31020","nvd":{"published":"2022-09-06T17:15:08.220","modified":"2026-06-17T04:44:37.220","status":"Modified","description":"Indy Node is the server portion of a distributed ledger purpose-built for decentralized identity. In versions 1.12.4 and prior, the `pool-upgrade` request handler in Indy-Node allows an improperly authenticated attacker to remotely execute code on nodes within the network. The `pool-upgrade` request handler in Indy-Node 1.12.5 has been updated to properly authenticate pool-upgrade transactions before any processing is performed by the request handler. The transactions are further sanitized to prevent remote code execution. As a workaround, endorsers should not create DIDs for untrusted users. A vulnerable ledger should configure `auth_rules` to prevent new DIDs from being written to the ledger until the network can be upgraded.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","score":8.8},"cwes":["CWE-20","CWE-287"],"references":["https://github.com/hyperledger/indy-node/commit/fe507474f77084faef4539101e2bbb4d508a97f5","https://github.com/hyperledger/indy-node/releases/tag/v1.12.5","https://github.com/hyperledger/indy-node/security/advisories/GHSA-r6v9-p59m-gj2p","https://github.com/hyperledger/indy-node/commit/fe507474f77084faef4539101e2bbb4d508a97f5","https://github.com/hyperledger/indy-node/releases/tag/v1.12.5"],"products":["linuxfoundation:indy-node"],"source":"nvd","synced_at":"2026-10-19T21:35:14.992143698+00:00"},"epss":{"cve":"CVE-2022-31020","score":0.02308,"percentile":0.83366,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-r6v9-p59m-gj2p","url":"https://osv.dev/vulnerability/GHSA-r6v9-p59m-gj2p","summary":"Indy's NODE_UPGRADE transaction vulnerable to remote code execution","modified":"2024-11-23T05:25:17.090178Z","packages":[{"ecosystem":"PyPI","name":"indy-node","purl":"pkg:pypi/indy-node","ranges":["<1.12.5rc1"],"fixed":["1.12.5rc1"]}]},{"id":"PYSEC-2022-265","url":"https://osv.dev/vulnerability/PYSEC-2022-265","summary":"","modified":"2023-11-08T04:09:22.844035Z","packages":[{"ecosystem":"PyPI","name":"indy-node","purl":"pkg:pypi/indy-node","ranges":["<1.12.5rc1"],"fixed":["1.12.5rc1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}