cve.bz

CVE-2022-25863

9.8 criticalEPSS 2.0%

Critical (9.8) in gatsbyjs gatsby-plugin-mdx. EPSS 2.0% chance of exploitation in the next 30 days. Fixed in gatsby-plugin-mdx 2.14.1, 3.15.2.

The package gatsby-plugin-mdx before 2.14.1, from 3.0.0 and before 3.15.2 are vulnerable to Deserialization of Untrusted Data when passing input through to the gray-matter package, due to its default configurations that are missing input sanitization. Exploiting this vulnerability is possible when passing input in both webpack (MDX files in src/pages or MDX file imported as a component in frontend / React code) and data mode (querying MDX nodes via GraphQL). Workaround: If an older version of gatsby-plugin-mdx must be used, input passed into the plugin should be sanitized ahead of processing.

Severity

CVSS 3.1

9.8 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
2.0% chance of exploitation in the next 30 days; higher than 80% of CVEs (scores of 2026-10-31)
CWE
CWE-502
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-mj46-r4gr-5x83npmgatsby-plugin-mdx<2.14.12.14.1
GHSA-mj46-r4gr-5x83npmgatsby-plugin-mdx>=3.0.0 <3.15.23.15.2

References

Check your stackJSON