{"cve":"CVE-2022-25863","nvd":{"published":"2022-06-10T20:15:08.227","modified":"2026-09-29T15:50:31.907","status":"Analyzed","description":"The package gatsby-plugin-mdx before 2.14.1, from 3.0.0 and before 3.15.2 are vulnerable to Deserialization of Untrusted Data when passing input through to the gray-matter package, due to its default configurations that are missing input sanitization. Exploiting this vulnerability is possible when passing input in both webpack (MDX files in src/pages or MDX file imported as a component in frontend / React code) and data mode (querying MDX nodes via GraphQL). Workaround: If an older version of gatsby-plugin-mdx must be used, input passed into the plugin should be sanitized ahead of processing.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","score":9.8},"cwes":["CWE-502"],"references":["https://drive.google.com/file/d/1EoCzbwTWOM8-fjvwMbH3bqcZ2iKksxTW/view?usp=sharing","https://github.com/gatsbyjs/gatsby/pull/35830","https://github.com/gatsbyjs/gatsby/pull/35830/commits/f214eb0694c61e348b2751cecd1aace2046bc46e","https://snyk.io/vuln/SNYK-JS-GATSBYPLUGINMDX-2405699","https://drive.google.com/file/d/1EoCzbwTWOM8-fjvwMbH3bqcZ2iKksxTW/view?usp=sharing"],"products":["gatsbyjs:gatsby-plugin-mdx"],"source":"nvd","synced_at":"2026-10-19T21:32:39.174919249+00:00"},"epss":{"cve":"CVE-2022-25863","score":0.01992,"percentile":0.80683,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-mj46-r4gr-5x83","url":"https://osv.dev/vulnerability/GHSA-mj46-r4gr-5x83","summary":"Unsanitized JavaScript code injection possible in gatsby-plugin-mdx","modified":"2026-07-08T06:50:01.480369243Z","packages":[{"ecosystem":"npm","name":"gatsby-plugin-mdx","purl":"pkg:npm/gatsby-plugin-mdx","ranges":["<2.14.1"],"fixed":["2.14.1"]},{"ecosystem":"npm","name":"gatsby-plugin-mdx","purl":"pkg:npm/gatsby-plugin-mdx","ranges":[">=3.0.0 <3.15.2"],"fixed":["3.15.2"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}