cve.bz

CVE-2022-24783

10.0 criticalEPSS 1.1%

Critical (10.0) in deno deno. EPSS 1.1% chance of exploitation in the next 30 days. Fixed in deno 1.20.3.

Deno is a runtime for JavaScript and TypeScript. The versions of Deno between release 1.18.0 and 1.20.2 (inclusive) are vulnerable to an attack where a malicious actor controlling the code executed in a Deno runtime could bypass all permission checks and execute arbitrary shell code. This vulnerability does not affect users of Deno Deploy. The vulnerability has been patched in Deno 1.20.3. There is no workaround. All users are recommended to upgrade to 1.20.3 immediately.

Severity

CVSS 3.1

10.0 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
EPSS
1.1% chance of exploitation in the next 30 days; higher than 66% of CVEs (scores of 2026-10-31)
CWEs
CWE-863, CWE-269
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-838h-jqp6-cf2fcrates.iodeno>=1.18.0 <1.20.31.20.3

References

Check your stackJSON