cve.bz

CVE-2022-21736

6.5 mediumEPSS 0.8%

Medium (6.5) in google tensorflow. EPSS 0.8% chance of exploitation in the next 30 days. Fixed in tensorflow 2.5.3, 2.6.3, 2.7.1.

Tensorflow is an Open Source Machine Learning Framework. The implementation of `SparseTensorSliceDataset` has an undefined behavior: under certain condition it can be made to dereference a `nullptr` value. The 3 input arguments to `SparseTensorSliceDataset` represent a sparse tensor. However, there are some preconditions that these arguments must satisfy but these are not validated in the implementation. The fix will be included in TensorFlow 2.8.0. We will also cherrypick this commit on TensorFlow 2.7.1, TensorFlow 2.6.3, and TensorFlow 2.5.3, as these are also affected and still in supported range.

Severity

CVSS 3.1

6.5 medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
0.8% chance of exploitation in the next 30 days; higher than 55% of CVEs (scores of 2026-10-31)
CWE
CWE-476
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-pfjj-m3jj-9jc9PyPItensorflow<2.5.32.5.3
GHSA-pfjj-m3jj-9jc9PyPItensorflow>=2.6.0 <2.6.32.6.3
GHSA-pfjj-m3jj-9jc9PyPItensorflow>=2.7.0 <2.7.12.7.1
GHSA-pfjj-m3jj-9jc9PyPItensorflow-cpu<2.5.32.5.3
GHSA-pfjj-m3jj-9jc9PyPItensorflow-cpu>=2.6.0 <2.6.32.6.3
GHSA-pfjj-m3jj-9jc9PyPItensorflow-cpu>=2.7.0 <2.7.12.7.1
GHSA-pfjj-m3jj-9jc9PyPItensorflow-gpu<2.5.32.5.3
GHSA-pfjj-m3jj-9jc9PyPItensorflow-gpu>=2.6.0 <2.6.32.6.3
GHSA-pfjj-m3jj-9jc9PyPItensorflow-gpu>=2.7.0 <2.7.12.7.1
PYSEC-2022-115PyPItensorflow-gpu<2.5.3
>=2.6.0 <2.6.3
2.5.3, 2.6.3
PYSEC-2022-60PyPItensorflow-cpu<2.5.3
>=2.6.0 <2.6.3
2.5.3, 2.6.3
PYSEC-2026-3223PyPItensorflow<2.5.3
>=2.6.0 <2.6.3
>=2.7.0 <2.7.1
2.5.3, 2.6.3, 2.7.1

References

Check your stackJSON