cve.bz

CVE-2022-21697

7.1 highEPSS 1.1%

High (7.1) in jupyter jupyter server proxy. EPSS 1.1% chance of exploitation in the next 30 days. Fixed in jupyter-server-proxy 3.2.1.

Jupyter Server Proxy is a Jupyter notebook server extension to proxy web services. Versions of Jupyter Server Proxy prior to 3.2.1 are vulnerable to Server-Side Request Forgery (SSRF). Any user deploying Jupyter Server or Notebook with jupyter-proxy-server extension enabled is affected. A lack of input validation allows authenticated clients to proxy requests to other hosts, bypassing the `allowed_hosts` check. Because authentication is required, which already grants permissions to make the same requests via kernel or terminal execution, this is considered low to moderate severity. Users may upgrade to version 3.2.1 to receive a patch or, as a workaround, install the patch manually.

Severity

CVSS 3.1

7.1 high
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N
EPSS
1.1% chance of exploitation in the next 30 days; higher than 65% of CVEs (scores of 2026-10-31)
CWE
CWE-918
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-gcv9-6737-pjqwPyPIjupyter-server-proxy<3.2.13.2.1
PYSEC-2022-16PyPIjupyter-server-proxy<3.2.13.2.1

References

Check your stackJSON