cve.bz

CVE-2021-4231

5.4 mediumEPSS 1.2%

A vulnerability was found in Angular up to 11.0.4/11.1.0-next.2. It has been classified as problematic. Affected is the handling of comments. The manipulation leads to cross site scripting. It is possible to launch the attack remotely but it might require an authentication first. Upgrading to version 11.0.5 and 11.1.0-next.3 is able to address this issue. The name of the patch is ba8da742e3b243e8f43d4c63aa842b44e14f2b09. It is recommended to upgrade the affected component.

Severity

CVSS 3.1

5.4 medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
EPSS
1.2% chance of exploitation in the next 30 days; higher than 67% of CVEs (scores of 2026-10-31)
CWE
CWE-79
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-c75v-2vq8-878fnpm@angular/core>=11.0.0 <11.0.511.0.5
GHSA-c75v-2vq8-878fnpm@angular/core>=11.1.0-next.0 <11.1.0-next.311.1.0-next.3
GHSA-c75v-2vq8-878fnpm@angular/core<10.2.510.2.5

References

Check your stackJSON