{"cve":"CVE-2021-4231","nvd":{"published":"2022-05-26T14:15:07.953","modified":"2026-06-17T04:19:18.927","status":"Modified","description":"A vulnerability was found in Angular up to 11.0.4/11.1.0-next.2. It has been classified as problematic. Affected is the handling of comments. The manipulation leads to cross site scripting. It is possible to launch the attack remotely but it might require an authentication first. Upgrading to version 11.0.5 and 11.1.0-next.3 is able to address this issue. The name of the patch is ba8da742e3b243e8f43d4c63aa842b44e14f2b09. It is recommended to upgrade the affected component.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","score":5.4},"cwes":["CWE-79"],"references":["https://github.com/angular/angular/commit/ba8da742e3b243e8f43d4c63aa842b44e14f2b09","https://github.com/angular/angular/issues/40136","https://security.snyk.io/vuln/SNYK-JS-ANGULARCORE-1070902","https://vuldb.com/?id.181356","https://github.com/angular/angular/commit/ba8da742e3b243e8f43d4c63aa842b44e14f2b09"],"products":["angular:angular","angularjs:angularjs"],"source":"nvd","synced_at":"2026-10-19T21:31:59.322382750+00:00"},"epss":{"cve":"CVE-2021-4231","score":0.01181,"percentile":0.67737,"date":"2026-11-01"},"kev":null,"osv":[{"id":"GHSA-c75v-2vq8-878f","url":"https://osv.dev/vulnerability/GHSA-c75v-2vq8-878f","summary":"Angular vulnerable to Cross-site Scripting","modified":"2026-09-10T03:49:21.863578485Z","packages":[{"ecosystem":"npm","name":"@angular/core","purl":"pkg:npm/%40angular/core","ranges":[">=11.0.0 <11.0.5"],"fixed":["11.0.5"]},{"ecosystem":"npm","name":"@angular/core","purl":"pkg:npm/%40angular/core","ranges":[">=11.1.0-next.0 <11.1.0-next.3"],"fixed":["11.1.0-next.3"]},{"ecosystem":"npm","name":"@angular/core","purl":"pkg:npm/%40angular/core","ranges":["<10.2.5"],"fixed":["10.2.5"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}