cve.bz

CVE-2021-37674

5.5 mediumEPSS 0.2%

Medium (5.5) in google tensorflow. EPSS 0.2% chance of exploitation in the next 30 days. Fixed in tensorflow 2.3.4, 2.4.3, 2.5.1.

TensorFlow is an end-to-end open source platform for machine learning. In affected versions an attacker can trigger a denial of service via a segmentation fault in `tf.raw_ops.MaxPoolGrad` caused by missing validation. The [implementation](https://github.com/tensorflow/tensorflow/blob/460e000de3a83278fb00b61a16d161b1964f15f4/tensorflow/core/kernels/maxpooling_op.cc) misses some validation for the `orig_input` and `orig_output` tensors. The fixes for CVE-2021-29579 were incomplete. We have patched the issue in GitHub commit 136b51f10903e044308cf77117c0ed9871350475. The fix will be included in TensorFlow 2.6.0. We will also cherrypick this commit on TensorFlow 2.5.1, TensorFlow 2.4.3, and TensorFlow 2.3.4, as these are also affected and still in supported range.

Severity

CVSS 3.1

5.5 medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
0.2% chance of exploitation in the next 30 days; higher than 7% of CVEs (scores of 2026-10-31)
CWEs
CWE-1284, CWE-20
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-7ghq-fvr3-pj2xPyPItensorflow<2.3.42.3.4
GHSA-7ghq-fvr3-pj2xPyPItensorflow>=2.4.0 <2.4.32.4.3
GHSA-7ghq-fvr3-pj2xPyPItensorflow>=2.5.0 <2.5.12.5.1
GHSA-7ghq-fvr3-pj2xPyPItensorflow-cpu<2.3.42.3.4
GHSA-7ghq-fvr3-pj2xPyPItensorflow-cpu>=2.4.0 <2.4.32.4.3
GHSA-7ghq-fvr3-pj2xPyPItensorflow-cpu>=2.5.0 <2.5.12.5.1
GHSA-7ghq-fvr3-pj2xPyPItensorflow-gpu<2.3.42.3.4
GHSA-7ghq-fvr3-pj2xPyPItensorflow-gpu>=2.4.0 <2.4.32.4.3
GHSA-7ghq-fvr3-pj2xPyPItensorflow-gpu>=2.5.0 <2.5.12.5.1
PYSEC-2021-296PyPItensorflow>=2.3.0 <2.3.4
>=2.4.0 <2.4.3
2.3.4, 2.4.3
PYSEC-2021-587PyPItensorflow-cpu>=2.3.0 <2.3.4
>=2.4.0 <2.4.3
2.3.4, 2.4.3
PYSEC-2021-785PyPItensorflow-gpu>=2.3.0 <2.3.4
>=2.4.0 <2.4.3
2.3.4, 2.4.3

References

Check your stackJSON