{"cve":"CVE-2021-37674","nvd":{"published":"2021-08-12T23:15:07.970","modified":"2026-06-17T04:00:57.430","status":"Modified","description":"TensorFlow is an end-to-end open source platform for machine learning. In affected versions an attacker can trigger a denial of service via a segmentation fault in `tf.raw_ops.MaxPoolGrad` caused by missing validation. The [implementation](https://github.com/tensorflow/tensorflow/blob/460e000de3a83278fb00b61a16d161b1964f15f4/tensorflow/core/kernels/maxpooling_op.cc) misses some validation for the `orig_input` and `orig_output` tensors. The fixes for CVE-2021-29579 were incomplete. We have patched the issue in GitHub commit 136b51f10903e044308cf77117c0ed9871350475. The fix will be included in TensorFlow 2.6.0. We will also cherrypick this commit on TensorFlow 2.5.1, TensorFlow 2.4.3, and TensorFlow 2.3.4, as these are also affected and still in supported range.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H","score":5.5},"cwes":["CWE-1284","CWE-20"],"references":["https://github.com/tensorflow/tensorflow/blob/master/tensorflow/security/advisory/tfsa-2021-068.md","https://github.com/tensorflow/tensorflow/commit/136b51f10903e044308cf77117c0ed9871350475","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-7ghq-fvr3-pj2x","https://github.com/tensorflow/tensorflow/blob/master/tensorflow/security/advisory/tfsa-2021-068.md","https://github.com/tensorflow/tensorflow/commit/136b51f10903e044308cf77117c0ed9871350475"],"products":["google:tensorflow"],"source":"nvd","synced_at":"2026-10-19T21:21:57.125947417+00:00"},"epss":{"cve":"CVE-2021-37674","score":0.00179,"percentile":0.07481,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-7ghq-fvr3-pj2x","url":"https://osv.dev/vulnerability/GHSA-7ghq-fvr3-pj2x","summary":"Incomplete validation in `MaxPoolGrad`","modified":"2026-07-08T06:29:02.787783792Z","packages":[{"ecosystem":"PyPI","name":"tensorflow","purl":"pkg:pypi/tensorflow","ranges":["<2.3.4"],"fixed":["2.3.4"]},{"ecosystem":"PyPI","name":"tensorflow","purl":"pkg:pypi/tensorflow","ranges":[">=2.4.0 <2.4.3"],"fixed":["2.4.3"]},{"ecosystem":"PyPI","name":"tensorflow","purl":"pkg:pypi/tensorflow","ranges":[">=2.5.0 <2.5.1"],"fixed":["2.5.1"]},{"ecosystem":"PyPI","name":"tensorflow-cpu","purl":"pkg:pypi/tensorflow-cpu","ranges":["<2.3.4"],"fixed":["2.3.4"]},{"ecosystem":"PyPI","name":"tensorflow-cpu","purl":"pkg:pypi/tensorflow-cpu","ranges":[">=2.4.0 <2.4.3"],"fixed":["2.4.3"]},{"ecosystem":"PyPI","name":"tensorflow-cpu","purl":"pkg:pypi/tensorflow-cpu","ranges":[">=2.5.0 <2.5.1"],"fixed":["2.5.1"]},{"ecosystem":"PyPI","name":"tensorflow-gpu","purl":"pkg:pypi/tensorflow-gpu","ranges":["<2.3.4"],"fixed":["2.3.4"]},{"ecosystem":"PyPI","name":"tensorflow-gpu","purl":"pkg:pypi/tensorflow-gpu","ranges":[">=2.4.0 <2.4.3"],"fixed":["2.4.3"]},{"ecosystem":"PyPI","name":"tensorflow-gpu","purl":"pkg:pypi/tensorflow-gpu","ranges":[">=2.5.0 <2.5.1"],"fixed":["2.5.1"]}]},{"id":"PYSEC-2021-296","url":"https://osv.dev/vulnerability/PYSEC-2021-296","summary":"","modified":"2023-12-06T01:01:23.602447Z","packages":[{"ecosystem":"PyPI","name":"tensorflow","purl":"pkg:pypi/tensorflow","ranges":[">=2.3.0 <2.3.4",">=2.4.0 <2.4.3"],"fixed":["2.3.4","2.4.3"]}]},{"id":"PYSEC-2021-587","url":"https://osv.dev/vulnerability/PYSEC-2021-587","summary":"","modified":"2023-12-06T01:01:23.602447Z","packages":[{"ecosystem":"PyPI","name":"tensorflow-cpu","purl":"pkg:pypi/tensorflow-cpu","ranges":[">=2.3.0 <2.3.4",">=2.4.0 <2.4.3"],"fixed":["2.3.4","2.4.3"]}]},{"id":"PYSEC-2021-785","url":"https://osv.dev/vulnerability/PYSEC-2021-785","summary":"","modified":"2023-12-06T01:01:23.602447Z","packages":[{"ecosystem":"PyPI","name":"tensorflow-gpu","purl":"pkg:pypi/tensorflow-gpu","ranges":[">=2.3.0 <2.3.4",">=2.4.0 <2.4.3"],"fixed":["2.3.4","2.4.3"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}