cve.bz

CVE-2021-37635

7.1 highEPSS 0.2%

High (7.1) in google tensorflow. EPSS 0.2% chance of exploitation in the next 30 days. Fixed in tensorflow 2.3.4, 2.4.3, 2.5.1.

TensorFlow is an end-to-end open source platform for machine learning. In affected versions the implementation of sparse reduction operations in TensorFlow can trigger accesses outside of bounds of heap allocated data. The [implementation](https://github.com/tensorflow/tensorflow/blob/a1bc56203f21a5a4995311825ffaba7a670d7747/tensorflow/core/kernels/sparse_reduce_op.cc#L217-L228) fails to validate that each reduction group does not overflow and that each corresponding index does not point to outside the bounds of the input tensor. We have patched the issue in GitHub commit 87158f43f05f2720a374f3e6d22a7aaa3a33f750. The fix will be included in TensorFlow 2.6.0. We will also cherrypick this commit on TensorFlow 2.5.1, TensorFlow 2.4.3, and TensorFlow 2.3.4, as these are also affected and still in supported range.

Severity

CVSS 3.1

7.1 high
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H
EPSS
0.2% chance of exploitation in the next 30 days; higher than 5% of CVEs (scores of 2026-10-31)
CWE
CWE-125
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-cgfm-62j4-v4rfPyPItensorflow<2.3.42.3.4
GHSA-cgfm-62j4-v4rfPyPItensorflow>=2.4.0 <2.4.32.4.3
GHSA-cgfm-62j4-v4rfPyPItensorflow>=2.5.0 <2.5.12.5.1
GHSA-cgfm-62j4-v4rfPyPItensorflow-cpu<2.3.42.3.4
GHSA-cgfm-62j4-v4rfPyPItensorflow-cpu>=2.4.0 <2.4.32.4.3
GHSA-cgfm-62j4-v4rfPyPItensorflow-cpu>=2.5.0 <2.5.12.5.1
GHSA-cgfm-62j4-v4rfPyPItensorflow-gpu<2.3.42.3.4
GHSA-cgfm-62j4-v4rfPyPItensorflow-gpu>=2.4.0 <2.4.32.4.3
GHSA-cgfm-62j4-v4rfPyPItensorflow-gpu>=2.5.0 <2.5.12.5.1
PYSEC-2021-257PyPItensorflow>=2.3.0 <2.3.4
>=2.4.0 <2.4.3
2.3.4, 2.4.3
PYSEC-2021-548PyPItensorflow-cpu>=2.3.0 <2.3.4
>=2.4.0 <2.4.3
2.3.4, 2.4.3
PYSEC-2021-746PyPItensorflow-gpu>=2.3.0 <2.3.4
>=2.4.0 <2.4.3
2.3.4, 2.4.3

References

Check your stackJSON