{"cve":"CVE-2021-37635","nvd":{"published":"2021-08-12T21:15:07.577","modified":"2026-06-17T04:00:52.523","status":"Modified","description":"TensorFlow is an end-to-end open source platform for machine learning. In affected versions the implementation of sparse reduction operations in TensorFlow can trigger accesses outside of bounds of heap allocated data. The [implementation](https://github.com/tensorflow/tensorflow/blob/a1bc56203f21a5a4995311825ffaba7a670d7747/tensorflow/core/kernels/sparse_reduce_op.cc#L217-L228) fails to validate that each reduction group does not overflow and that each corresponding index does not point to outside the bounds of the input tensor. We have patched the issue in GitHub commit 87158f43f05f2720a374f3e6d22a7aaa3a33f750. The fix will be included in TensorFlow 2.6.0. We will also cherrypick this commit on TensorFlow 2.5.1, TensorFlow 2.4.3, and TensorFlow 2.3.4, as these are also affected and still in supported range.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H","score":7.1},"cwes":["CWE-125"],"references":["https://github.com/tensorflow/tensorflow/commit/87158f43f05f2720a374f3e6d22a7aaa3a33f750","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-cgfm-62j4-v4rf","https://github.com/tensorflow/tensorflow/commit/87158f43f05f2720a374f3e6d22a7aaa3a33f750","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-cgfm-62j4-v4rf"],"products":["google:tensorflow"],"source":"nvd","synced_at":"2026-10-19T21:21:57.125947417+00:00"},"epss":{"cve":"CVE-2021-37635","score":0.00167,"percentile":0.05972,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-cgfm-62j4-v4rf","url":"https://osv.dev/vulnerability/GHSA-cgfm-62j4-v4rf","summary":"Heap out of bounds access in sparse reduction operations","modified":"2026-07-08T06:27:47.948439360Z","packages":[{"ecosystem":"PyPI","name":"tensorflow","purl":"pkg:pypi/tensorflow","ranges":["<2.3.4"],"fixed":["2.3.4"]},{"ecosystem":"PyPI","name":"tensorflow","purl":"pkg:pypi/tensorflow","ranges":[">=2.4.0 <2.4.3"],"fixed":["2.4.3"]},{"ecosystem":"PyPI","name":"tensorflow","purl":"pkg:pypi/tensorflow","ranges":[">=2.5.0 <2.5.1"],"fixed":["2.5.1"]},{"ecosystem":"PyPI","name":"tensorflow-cpu","purl":"pkg:pypi/tensorflow-cpu","ranges":["<2.3.4"],"fixed":["2.3.4"]},{"ecosystem":"PyPI","name":"tensorflow-cpu","purl":"pkg:pypi/tensorflow-cpu","ranges":[">=2.4.0 <2.4.3"],"fixed":["2.4.3"]},{"ecosystem":"PyPI","name":"tensorflow-cpu","purl":"pkg:pypi/tensorflow-cpu","ranges":[">=2.5.0 <2.5.1"],"fixed":["2.5.1"]},{"ecosystem":"PyPI","name":"tensorflow-gpu","purl":"pkg:pypi/tensorflow-gpu","ranges":["<2.3.4"],"fixed":["2.3.4"]},{"ecosystem":"PyPI","name":"tensorflow-gpu","purl":"pkg:pypi/tensorflow-gpu","ranges":[">=2.4.0 <2.4.3"],"fixed":["2.4.3"]},{"ecosystem":"PyPI","name":"tensorflow-gpu","purl":"pkg:pypi/tensorflow-gpu","ranges":[">=2.5.0 <2.5.1"],"fixed":["2.5.1"]}]},{"id":"PYSEC-2021-257","url":"https://osv.dev/vulnerability/PYSEC-2021-257","summary":"","modified":"2023-12-06T01:01:21.240407Z","packages":[{"ecosystem":"PyPI","name":"tensorflow","purl":"pkg:pypi/tensorflow","ranges":[">=2.3.0 <2.3.4",">=2.4.0 <2.4.3"],"fixed":["2.3.4","2.4.3"]}]},{"id":"PYSEC-2021-548","url":"https://osv.dev/vulnerability/PYSEC-2021-548","summary":"","modified":"2023-12-06T01:01:21.240407Z","packages":[{"ecosystem":"PyPI","name":"tensorflow-cpu","purl":"pkg:pypi/tensorflow-cpu","ranges":[">=2.3.0 <2.3.4",">=2.4.0 <2.4.3"],"fixed":["2.3.4","2.4.3"]}]},{"id":"PYSEC-2021-746","url":"https://osv.dev/vulnerability/PYSEC-2021-746","summary":"","modified":"2023-12-06T01:01:21.240407Z","packages":[{"ecosystem":"PyPI","name":"tensorflow-gpu","purl":"pkg:pypi/tensorflow-gpu","ranges":[">=2.3.0 <2.3.4",">=2.4.0 <2.4.3"],"fixed":["2.3.4","2.4.3"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}