cve.bz

CVE-2021-3583

7.1 highEPSS 0.9%

High (7.1) in redhat. EPSS 0.9% chance of exploitation in the next 30 days. Fixed in ansible 2.10.11rc1, 2.11.2rc1, 2.9.23.

A flaw was found in Ansible, where a user's controller is vulnerable to template injection. This issue can occur through facts used in the template if the user is trying to put templates in multi-line YAML strings and the facts being handled do not routinely include special template characters. This flaw allows attackers to perform command injection, which discloses sensitive information. The highest threat from this vulnerability is to confidentiality and integrity.

Severity

CVSS 3.1

7.1 high
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
EPSS
0.9% chance of exploitation in the next 30 days; higher than 59% of CVEs (scores of 2026-10-31)
CWEs
CWE-94, CWE-20
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-2pfh-q76x-gwvmPyPIansible<2.9.23rc12.9.23rc1
GHSA-2pfh-q76x-gwvmPyPIansible>=2.10.0a1 <2.10.11rc12.10.11rc1
GHSA-2pfh-q76x-gwvmPyPIansible>=2.11.0a1 <2.11.2rc12.11.2rc1
PYSEC-2021-358PyPIansible<2.9.232.9.23

References

Check your stackJSON