{"cve":"CVE-2021-3583","nvd":{"published":"2021-09-22T12:15:07.953","modified":"2026-06-17T04:05:23.190","status":"Modified","description":"A flaw was found in Ansible, where a user's controller is vulnerable to template injection. This issue can occur through facts used in the template if the user is trying to put templates in multi-line YAML strings and the facts being handled do not routinely include special template characters. This flaw allows attackers to perform command injection, which discloses sensitive information. The highest threat from this vulnerability is to confidentiality and integrity.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N","score":7.1},"cwes":["CWE-94","CWE-20"],"references":["https://bugzilla.redhat.com/show_bug.cgi?id=1968412","https://lists.debian.org/debian-lts-announce/2023/12/msg00018.html","https://bugzilla.redhat.com/show_bug.cgi?id=1968412","https://lists.debian.org/debian-lts-announce/2023/12/msg00018.html"],"products":["redhat:ansible_automation_platform","redhat:ansible_engine","redhat:ansible_tower"],"source":"nvd","synced_at":"2026-10-19T21:23:41.316049955+00:00"},"epss":{"cve":"CVE-2021-3583","score":0.00897,"percentile":0.59583,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-2pfh-q76x-gwvm","url":"https://osv.dev/vulnerability/GHSA-2pfh-q76x-gwvm","summary":"Improper Input Validation and Command Injection in Ansible","modified":"2024-09-06T18:01:00.918391Z","packages":[{"ecosystem":"PyPI","name":"ansible","purl":"pkg:pypi/ansible","ranges":["<2.9.23rc1"],"fixed":["2.9.23rc1"]},{"ecosystem":"PyPI","name":"ansible","purl":"pkg:pypi/ansible","ranges":[">=2.10.0a1 <2.10.11rc1"],"fixed":["2.10.11rc1"]},{"ecosystem":"PyPI","name":"ansible","purl":"pkg:pypi/ansible","ranges":[">=2.11.0a1 <2.11.2rc1"],"fixed":["2.11.2rc1"]}]},{"id":"PYSEC-2021-358","url":"https://osv.dev/vulnerability/PYSEC-2021-358","summary":"","modified":"2023-11-08T04:06:10.619764Z","packages":[{"ecosystem":"PyPI","name":"ansible","purl":"pkg:pypi/ansible","ranges":["<2.9.23"],"fixed":["2.9.23"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}