cve.bz

CVE-2021-32811

7.2 highEPSS 2.3%

High (7.2) in zope. EPSS 2.3% chance of exploitation in the next 30 days. Fixed in zope 4.6.3, 5.3.

Zope is an open-source web application server. Zope versions prior to versions 4.6.3 and 5.3 have a remote code execution security issue. In order to be affected, one must use Python 3 for one's Zope deployment, run Zope 4 below version 4.6.3 or Zope 5 below version 5.3, and have the optional `Products.PythonScripts` add-on package installed. By default, one must have the admin-level Zope "Manager" role to add or edit Script (Python) objects through the web. Only sites that allow untrusted users to add/edit these scripts through the web are at risk. Zope releases 4.6.3 and 5.3 are not vulnerable. As a workaround, a site administrator can restrict adding/editing Script (Python) objects through the web using the standard Zope user/role permission mechanisms. Untrusted users should not be assigned the Zope Manager role and adding/editing these scripts through the web should be restricted to trusted users only. This is the default configuration in Zope.

Severity

CVSS 3.1

7.2 high
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
EPSS
2.3% chance of exploitation in the next 30 days; higher than 83% of CVEs (scores of 2026-10-31)
CWEs
CWE-1321, CWE-915
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-g4gq-j4p2-j8frPyPIzope>=4.0 <4.6.34.6.3
GHSA-g4gq-j4p2-j8frPyPIzope>=5.0 <5.35.3
PYSEC-2021-368PyPIzope>=4.0 <4.6.3
>=5.0 <5.3
4.6.3, 5.3
PYSEC-2021-370PyPIaccesscontrol>=4.0 <4.3
>=5.0 <5.2
4.3, 5.2

References

Check your stackJSON