{"cve":"CVE-2021-32811","nvd":{"published":"2021-08-02T22:15:08.333","modified":"2026-06-17T03:53:40.800","status":"Modified","description":"Zope is an open-source web application server. Zope versions prior to versions 4.6.3 and 5.3 have a remote code execution security issue. In order to be affected, one must use Python 3 for one's Zope deployment, run Zope 4 below version 4.6.3 or Zope 5 below version 5.3, and have the optional `Products.PythonScripts` add-on package installed. By default, one must have the admin-level Zope \"Manager\" role to add or edit Script (Python) objects through the web. Only sites that allow untrusted users to add/edit these scripts through the web are at risk. Zope releases 4.6.3 and 5.3 are not vulnerable. As a workaround, a site administrator can restrict adding/editing Script (Python) objects through the web using the standard Zope user/role permission mechanisms. Untrusted users should not be assigned the Zope Manager role and adding/editing these scripts through the web should be restricted to trusted users only. This is the default configuration in Zope.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H","score":7.2},"cwes":["CWE-1321","CWE-915"],"references":["https://github.com/zopefoundation/AccessControl/security/advisories/GHSA-qcx9-j53g-ccgf","https://github.com/zopefoundation/Zope/commit/f72a18dda8e9bf2aedb46168761668464a4be988","https://github.com/zopefoundation/Zope/security/advisories/GHSA-g4gq-j4p2-j8fr","https://github.com/zopefoundation/AccessControl/security/advisories/GHSA-qcx9-j53g-ccgf","https://github.com/zopefoundation/Zope/commit/f72a18dda8e9bf2aedb46168761668464a4be988"],"products":["zope:accesscontrol","zope:zope"],"source":"nvd","synced_at":"2026-10-19T21:21:13.713336758+00:00"},"epss":{"cve":"CVE-2021-32811","score":0.02296,"percentile":0.83268,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-g4gq-j4p2-j8fr","url":"https://osv.dev/vulnerability/GHSA-g4gq-j4p2-j8fr","summary":"Remote Code Execution via Script (Python) objects under Python 3","modified":"2026-07-09T16:56:40.110056749Z","packages":[{"ecosystem":"PyPI","name":"zope","purl":"pkg:pypi/zope","ranges":[">=4.0 <4.6.3"],"fixed":["4.6.3"]},{"ecosystem":"PyPI","name":"zope","purl":"pkg:pypi/zope","ranges":[">=5.0 <5.3"],"fixed":["5.3"]}]},{"id":"PYSEC-2021-368","url":"https://osv.dev/vulnerability/PYSEC-2021-368","summary":"","modified":"2026-07-09T16:56:40.110056749Z","packages":[{"ecosystem":"PyPI","name":"zope","purl":"pkg:pypi/zope","ranges":[">=4.0 <4.6.3",">=5.0 <5.3"],"fixed":["4.6.3","5.3"]}]},{"id":"PYSEC-2021-370","url":"https://osv.dev/vulnerability/PYSEC-2021-370","summary":"","modified":"2026-07-09T16:56:40.110056749Z","packages":[{"ecosystem":"PyPI","name":"accesscontrol","purl":"pkg:pypi/accesscontrol","ranges":[">=4.0 <4.3",">=5.0 <5.2"],"fixed":["4.3","5.2"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}