cve.bz

CVE-2021-32770

7.5 highEPSS 1.4%

High (7.5) in gatsbyjs gatsby-source-wordpress. EPSS 1.4% chance of exploitation in the next 30 days. Fixed in gatsby-source-wordpress 4.0.8, 5.9.2.

Gatsby is a framework for building websites. The gatsby-source-wordpress plugin prior to versions 4.0.8 and 5.9.2 leaks .htaccess HTTP Basic Authentication variables into the app.js bundle during build-time. Users who are not initializing basic authentication credentials in the gatsby-config.js are not affected. A patch has been introduced in gatsby-source-wordpress@4.0.8 and gatsby-source-wordpress@5.9.2 which mitigates the issue by filtering all variables specified in the `auth: { }` section. Users that depend on this functionality are advised to upgrade to the latest release of gatsby-source-wordpress, run `gatsby clean` followed by a `gatsby build`. One may manually edit the app.js file post-build as a workaround.

Severity

CVSS 3.1

7.5 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
1.4% chance of exploitation in the next 30 days; higher than 72% of CVEs (scores of 2026-10-31)
CWEs
CWE-522, CWE-200
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-rqjw-p5vr-c695npmgatsby-source-wordpress<4.0.84.0.8
GHSA-rqjw-p5vr-c695npmgatsby-source-wordpress>=5.0.0 <5.9.25.9.2

References

Check your stackJSON