{"cve":"CVE-2021-32770","nvd":{"published":"2021-07-15T19:15:07.920","modified":"2026-06-17T03:53:35.677","status":"Modified","description":"Gatsby is a framework for building websites. The gatsby-source-wordpress plugin prior to versions 4.0.8 and 5.9.2 leaks .htaccess HTTP Basic Authentication variables into the app.js bundle during build-time. Users who are not initializing basic authentication credentials in the gatsby-config.js are not affected. A patch has been introduced in gatsby-source-wordpress@4.0.8 and gatsby-source-wordpress@5.9.2 which mitigates the issue by filtering all variables specified in the `auth: { }` section. Users that depend on this functionality are advised to upgrade to the latest release of gatsby-source-wordpress, run `gatsby clean` followed by a `gatsby build`. One may manually edit the app.js file post-build as a workaround.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","score":7.5},"cwes":["CWE-522","CWE-200"],"references":["https://github.com/gatsbyjs/gatsby/security/advisories/GHSA-rqjw-p5vr-c695","https://github.com/gatsbyjs/gatsby/security/advisories/GHSA-rqjw-p5vr-c695"],"products":["gatsbyjs:gatsby-source-wordpress"],"source":"nvd","synced_at":"2026-10-19T21:21:13.713336758+00:00"},"epss":{"cve":"CVE-2021-32770","score":0.01414,"percentile":0.72735,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-rqjw-p5vr-c695","url":"https://osv.dev/vulnerability/GHSA-rqjw-p5vr-c695","summary":"Basic-auth app bundle credential exposure in gatsby-source-wordpress","modified":"2026-07-08T06:29:24.203273428Z","packages":[{"ecosystem":"npm","name":"gatsby-source-wordpress","purl":"pkg:npm/gatsby-source-wordpress","ranges":["<4.0.8"],"fixed":["4.0.8"]},{"ecosystem":"npm","name":"gatsby-source-wordpress","purl":"pkg:npm/gatsby-source-wordpress","ranges":[">=5.0.0 <5.9.2"],"fixed":["5.9.2"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}