Medium (6.1) in auth0 nextjs-auth0. EPSS 1.4% chance of exploitation in the next 30 days. Fixed in @auth0/nextjs-auth0 1.4.2.
The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. Versions before and including `1.4.1` are vulnerable to reflected XSS. An attacker can execute arbitrary code by providing an XSS payload in the `error` query parameter which is then processed by the callback handler as an error message. You are affected by this vulnerability if you are using `@auth0/nextjs-auth0` version `1.4.1` or lower **unless** you are using custom error handling that does not return the error message in an HTML response. Upgrade to version `1.4.1` to resolve. The fix adds basic HTML escaping to the error message and it should not impact your users.
Severity
CVSS 3.1
6.1 medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
1.4% chance of exploitation in the next 30 days; higher than 72% of CVEs (scores of 2026-10-31)