{"cve":"CVE-2021-32702","nvd":{"published":"2021-06-25T17:15:08.383","modified":"2026-06-17T03:53:27.480","status":"Modified","description":"The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. Versions before and including `1.4.1` are vulnerable to reflected XSS. An attacker can execute arbitrary code by providing an XSS payload in the `error` query parameter which is then processed by the callback handler as an error message. You are affected by this vulnerability if you are using `@auth0/nextjs-auth0` version `1.4.1` or lower **unless** you are using custom error handling that does not return the error message in an HTML response. Upgrade to version `1.4.1` to resolve. The fix adds basic HTML escaping to the error message and it should not impact your users.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","score":6.1},"cwes":["CWE-79"],"references":["https://github.com/auth0/nextjs-auth0/commit/6996e2528ceed98627caa28abafbc09e90163ccf","https://github.com/auth0/nextjs-auth0/security/advisories/GHSA-954c-jjx6-cxv7","https://www.npmjs.com/package/%40auth0/nextjs-auth0","https://github.com/auth0/nextjs-auth0/commit/6996e2528ceed98627caa28abafbc09e90163ccf","https://github.com/auth0/nextjs-auth0/security/advisories/GHSA-954c-jjx6-cxv7"],"products":["auth0:nextjs-auth0"],"source":"nvd","synced_at":"2026-10-19T21:20:07.141963181+00:00"},"epss":{"cve":"CVE-2021-32702","score":0.01403,"percentile":0.7256,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-954c-jjx6-cxv7","url":"https://osv.dev/vulnerability/GHSA-954c-jjx6-cxv7","summary":"Reflected XSS from the callback handler's error query parameter","modified":"2026-07-08T06:29:07.810465813Z","packages":[{"ecosystem":"npm","name":"@auth0/nextjs-auth0","purl":"pkg:npm/%40auth0/nextjs-auth0","ranges":["<1.4.2"],"fixed":["1.4.2"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}