cve.bz

CVE-2021-29515

7.8 highEPSS 0.2%

High (7.8) in google tensorflow. EPSS 0.2% chance of exploitation in the next 30 days. Fixed in tensorflow 2.1.4, 2.2.3, 2.3.3.

TensorFlow is an end-to-end open source platform for machine learning. The implementation of `MatrixDiag*` operations(https://github.com/tensorflow/tensorflow/blob/4c4f420e68f1cfaf8f4b6e8e3eb857e9e4c3ff33/tensorflow/core/kernels/linalg/matrix_diag_op.cc#L195-L197) does not validate that the tensor arguments are non-empty. The fix will be included in TensorFlow 2.5.0. We will also cherrypick this commit on TensorFlow 2.4.2, TensorFlow 2.3.3, TensorFlow 2.2.3 and TensorFlow 2.1.4, as these are also affected and still in supported range.

Severity

CVSS 3.1

7.8 high
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
0.2% chance of exploitation in the next 30 days; higher than 10% of CVEs (scores of 2026-10-31)
CWE
CWE-476
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-hc6c-75p4-hmq4PyPItensorflow<2.1.42.1.4
GHSA-hc6c-75p4-hmq4PyPItensorflow>=2.2.0 <2.2.32.2.3
GHSA-hc6c-75p4-hmq4PyPItensorflow>=2.3.0 <2.3.32.3.3
GHSA-hc6c-75p4-hmq4PyPItensorflow>=2.4.0 <2.4.22.4.2
GHSA-hc6c-75p4-hmq4PyPItensorflow-cpu<2.1.42.1.4
GHSA-hc6c-75p4-hmq4PyPItensorflow-cpu>=2.2.0 <2.2.32.2.3
GHSA-hc6c-75p4-hmq4PyPItensorflow-cpu>=2.3.0 <2.3.32.3.3
GHSA-hc6c-75p4-hmq4PyPItensorflow-cpu>=2.4.0 <2.4.22.4.2
GHSA-hc6c-75p4-hmq4PyPItensorflow-gpu<2.1.42.1.4
GHSA-hc6c-75p4-hmq4PyPItensorflow-gpu>=2.2.0 <2.2.32.2.3
GHSA-hc6c-75p4-hmq4PyPItensorflow-gpu>=2.3.0 <2.3.32.3.3
GHSA-hc6c-75p4-hmq4PyPItensorflow-gpu>=2.4.0 <2.4.22.4.2
PYSEC-2021-152PyPItensorflow<2.1.4
>=2.2.0 <2.2.3
>=2.3.0 <2.3.3
>=2.4.0 <2.4.2
2.1.4, 2.2.3, 2.3.3, 2.4.2
PYSEC-2021-443PyPItensorflow-cpu<2.1.4
>=2.2.0 <2.2.3
>=2.3.0 <2.3.3
>=2.4.0 <2.4.2
2.1.4, 2.2.3, 2.3.3, 2.4.2
PYSEC-2021-641PyPItensorflow-gpu<2.1.4
>=2.2.0 <2.2.3
>=2.3.0 <2.3.3
>=2.4.0 <2.4.2
2.1.4, 2.2.3, 2.3.3, 2.4.2

References

Check your stackJSON