cve.bz

CVE-2021-29435

6.5 mediumEPSS 0.7%

Medium (6.5) in trestle-auth project trestle-auth. EPSS 0.7% chance of exploitation in the next 30 days. Fixed in trestle-auth 0.4.2.

trestle-auth is an authentication plugin for the Trestle admin framework. A vulnerability in trestle-auth versions 0.4.0 and 0.4.1 allows an attacker to create a form that will bypass Rails' built-in CSRF protection when submitted by a victim with a trestle-auth admin session. This potentially allows an attacker to alter protected data, including admin account credentials. The vulnerability has been fixed in trestle-auth 0.4.2 released to RubyGems.

Severity

CVSS 3.1

6.5 medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N
EPSS
0.7% chance of exploitation in the next 30 days; higher than 51% of CVEs (scores of 2026-10-31)
CWE
CWE-352
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-h8hx-2c5r-32cfRubyGemstrestle-auth>=0.4.0 <0.4.20.4.2

References

Check your stackJSON