cve.bz

CVE-2021-27191

7.5 highEPSS 2.0%

High (7.5) in get-ip-range project get-ip-range. EPSS 2.0% chance of exploitation in the next 30 days. Fixed in get-ip-range 4.0.0.

The get-ip-range package before 4.0.0 for Node.js is vulnerable to denial of service (DoS) if the range is untrusted input. An attacker could send a large range (such as 128.0.0.0/1) that causes resource exhaustion.

Severity

CVSS 3.1

7.5 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
2.0% chance of exploitation in the next 30 days; higher than 81% of CVEs (scores of 2026-10-31)
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-6q4w-3wp4-q5wfnpmget-ip-range<4.0.04.0.0

References

Check your stackJSON