{"cve":"CVE-2021-27191","nvd":{"published":"2021-02-11T18:15:18.347","modified":"2026-06-17T03:44:26.293","status":"Modified","description":"The get-ip-range package before 4.0.0 for Node.js is vulnerable to denial of service (DoS) if the range is untrusted input. An attacker could send a large range (such as 128.0.0.0/1) that causes resource exhaustion.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","score":7.5},"cwes":[],"references":["https://advisory.checkmarx.net/advisory/CX-2021-4304","https://github.com/JoeScho/get-ip-range/commit/98ca22b815c77273cbab259811ab0976118e13b6","https://security.netapp.com/advisory/ntap-20210319-0002/","https://www.npmjs.com/package/get-ip-range","https://advisory.checkmarx.net/advisory/CX-2021-4304"],"products":["get-ip-range_project:get-ip-range"],"source":"nvd","synced_at":"2026-10-19T21:14:10.479542811+00:00"},"epss":{"cve":"CVE-2021-27191","score":0.02031,"percentile":0.8105,"date":"2026-11-01"},"kev":null,"osv":[{"id":"GHSA-6q4w-3wp4-q5wf","url":"https://osv.dev/vulnerability/GHSA-6q4w-3wp4-q5wf","summary":"Denial of Service in get-ip-range","modified":"2023-11-08T04:05:23.815655Z","packages":[{"ecosystem":"npm","name":"get-ip-range","purl":"pkg:npm/get-ip-range","ranges":["<4.0.0"],"fixed":["4.0.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}