cve.bz

CVE-2021-23718

7.5 highEPSS 1.6%

High (7.5) in ssrf-agent project ssrf-agent. EPSS 1.6% chance of exploitation in the next 30 days. Fixed in ssrf-agent 1.0.5.

The package ssrf-agent before 1.0.5 are vulnerable to Server-side Request Forgery (SSRF) via the defaultIpChecker function. It fails to properly validate if the IP requested is private.

Severity

CVSS 3.1

7.5 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
1.6% chance of exploitation in the next 30 days; higher than 76% of CVEs (scores of 2026-10-31)
CWE
CWE-918
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-6gww-qpm6-mc2gnpmssrf-agent<1.0.51.0.5

References

Check your stackJSON