cve.bz

CVE-2021-21336

6.5 mediumEPSS 1.5%

Medium (6.5). EPSS 1.5% chance of exploitation in the next 30 days. Fixed in products-pluggableauthservice 2.6.0.

Products.PluggableAuthService is a pluggable Zope authentication and authorization framework. In Products.PluggableAuthService before version 2.6.0 there is an information disclosure vulnerability - everyone can list the names of roles defined in the ZODB Role Manager plugin if the site uses this plugin. The problem has been fixed in version 2.6.0. Depending on how you have installed Products.PluggableAuthService, you should change the buildout version pin to 2.6.0 and re-run the buildout, or if you used pip simply do `pip install "Products.PluggableAuthService>=2.6.0"`.

Severity

CVSS 3.1

6.5 medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
EPSS
1.5% chance of exploitation in the next 30 days; higher than 74% of CVEs (scores of 2026-10-31)
CWE
CWE-200
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-p75f-g7gx-2r7pPyPIproducts-pluggableauthservice<2.6.02.6.0
PYSEC-2021-44PyPIproducts-pluggableauthservice<2.6.02.6.0

References

Check your stackJSON