{"cve":"CVE-2021-21336","nvd":{"published":"2021-03-08T21:15:16.683","modified":"2026-06-17T03:35:19.470","status":"Modified","description":"Products.PluggableAuthService is a pluggable Zope authentication and authorization framework. In Products.PluggableAuthService before version 2.6.0 there is an information disclosure vulnerability - everyone can list the names of roles defined in the ZODB Role Manager plugin if the site uses this plugin. The problem has been fixed in version 2.6.0. Depending on how you have installed Products.PluggableAuthService, you should change the buildout version pin to 2.6.0 and re-run the buildout, or if you used pip simply do `pip install \"Products.PluggableAuthService>=2.6.0\"`.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","score":6.5},"cwes":["CWE-200"],"references":["http://www.openwall.com/lists/oss-security/2021/05/21/1","http://www.openwall.com/lists/oss-security/2021/05/22/1","https://github.com/zopefoundation/Products.PluggableAuthService/commit/2dad81128250cb2e5d950cddc9d3c0314a80b4bb","https://github.com/zopefoundation/Products.PluggableAuthService/security/advisories/GHSA-p75f-g7gx-2r7p","https://pypi.org/project/Products.PluggableAuthService/"],"products":["plone:plone","zope:products.pluggableauthservice"],"source":"nvd","synced_at":"2026-10-19T21:15:50.279857260+00:00"},"epss":{"cve":"CVE-2021-21336","score":0.01499,"percentile":0.74271,"date":"2026-11-01"},"kev":null,"osv":[{"id":"GHSA-p75f-g7gx-2r7p","url":"https://osv.dev/vulnerability/GHSA-p75f-g7gx-2r7p","summary":"Exposure of Sensitive Information to an Unauthorized Actor in Products.PluggableAuthService ZODBRoleManager","modified":"2026-07-08T06:29:24.826616013Z","packages":[{"ecosystem":"PyPI","name":"products-pluggableauthservice","purl":"pkg:pypi/products-pluggableauthservice","ranges":["<2.6.0"],"fixed":["2.6.0"]}]},{"id":"PYSEC-2021-44","url":"https://osv.dev/vulnerability/PYSEC-2021-44","summary":"","modified":"2023-11-08T04:04:41.761487Z","packages":[{"ecosystem":"PyPI","name":"products-pluggableauthservice","purl":"pkg:pypi/products-pluggableauthservice","ranges":["<2.6.0"],"fixed":["2.6.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}