cve.bz

CVE-2021-21241

7.4 highEPSS 0.9%

High (7.4) in flask-security-too project flask-security-too. EPSS 0.9% chance of exploitation in the next 30 days. Fixed in flask-security-too 3.4.5.

The Python "Flask-Security-Too" package is used for adding security features to your Flask application. It is an is a independently maintained version of Flask-Security based on the 3.0.0 version of Flask-Security. In Flask-Security-Too from version 3.3.0 and before version 3.4.5, the /login and /change endpoints can return the authenticated user's authentication token in response to a GET request. Since GET requests aren't protected with a CSRF token, this could lead to a malicious 3rd party site acquiring the authentication token. Version 3.4.5 and version 4.0.0 are patched. As a workaround, if you aren't using authentication tokens - you can set the SECURITY_TOKEN_MAX_AGE to "0" (seconds) which should make the token unusable.

Severity

CVSS 3.1

7.4 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:N/A:N
EPSS
0.9% chance of exploitation in the next 30 days; higher than 60% of CVEs (scores of 2026-10-31)
CWE
CWE-352
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-hh7m-rx4f-4vpvPyPIflask-security-too>=3.3.0 <3.4.53.4.5
PYSEC-2021-91PyPIflask-security-too>=3.3.0 <3.4.53.4.5

References

Check your stackJSON