{"cve":"CVE-2021-21241","nvd":{"published":"2021-01-11T21:15:13.377","modified":"2026-06-17T03:35:06.603","status":"Modified","description":"The Python \"Flask-Security-Too\" package is used for adding security features to your Flask application. It is an is a independently maintained version of Flask-Security based on the 3.0.0 version of Flask-Security. In Flask-Security-Too from version 3.3.0 and before version 3.4.5, the /login and /change endpoints can return the authenticated user's authentication token in response to a GET request. Since GET requests aren't protected with a CSRF token, this could lead to a malicious 3rd party site acquiring the authentication token. Version 3.4.5 and version 4.0.0 are patched. As a workaround, if you aren't using authentication tokens - you can set the SECURITY_TOKEN_MAX_AGE to \"0\" (seconds) which should make the token unusable.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:N/A:N","score":7.4},"cwes":["CWE-352"],"references":["https://github.com/Flask-Middleware/flask-security/commit/61d313150b5f620d0b800896c4f2199005e84b1f","https://github.com/Flask-Middleware/flask-security/commit/6d50ee9169acf813257c37b75babe9c28e83542a","https://github.com/Flask-Middleware/flask-security/pull/422","https://github.com/Flask-Middleware/flask-security/releases/tag/3.4.5","https://github.com/Flask-Middleware/flask-security/security/advisories/GHSA-hh7m-rx4f-4vpv"],"products":["flask-security-too_project:flask-security-too"],"source":"nvd","synced_at":"2026-10-19T21:12:09.559580076+00:00"},"epss":{"cve":"CVE-2021-21241","score":0.00928,"percentile":0.60542,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-hh7m-rx4f-4vpv","url":"https://osv.dev/vulnerability/GHSA-hh7m-rx4f-4vpv","summary":"CSRF can expose users authentication token","modified":"2026-03-13T22:16:07.774320Z","packages":[{"ecosystem":"PyPI","name":"flask-security-too","purl":"pkg:pypi/flask-security-too","ranges":[">=3.3.0 <3.4.5"],"fixed":["3.4.5"]}]},{"id":"PYSEC-2021-91","url":"https://osv.dev/vulnerability/PYSEC-2021-91","summary":"","modified":"2023-11-08T04:04:39.251638Z","packages":[{"ecosystem":"PyPI","name":"flask-security-too","purl":"pkg:pypi/flask-security-too","ranges":[">=3.3.0 <3.4.5"],"fixed":["3.4.5"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}