cve.bz

CVE-2020-5216

5.8 mediumEPSS 1.2%

In Secure Headers (RubyGem secure_headers), a directive injection vulnerability is present in versions before 3.9.0, 5.2.0, and 6.3.0. If user-supplied input was passed into append/override_content_security_policy_directives, a newline could be injected leading to limited header injection. Upon seeing a newline in the header, rails will silently create a new Content-Security-Policy header with the remaining value of the original string. It will continue to create new headers for each newline. This has been fixed in 6.3.0, 5.2.0, and 3.9.0.

Severity

CVSS 3.1

5.8 medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:L/A:N
EPSS
1.2% chance of exploitation in the next 30 days; higher than 68% of CVEs (scores of 2026-10-31)
CWEs
CWE-74, CWE-113
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-w978-rmpf-qmwgRubyGemssecure_headers>=6.0.0 <6.3.06.3.0
GHSA-w978-rmpf-qmwgRubyGemssecure_headers>=5.0.0 <5.2.05.2.0
GHSA-w978-rmpf-qmwgRubyGemssecure_headers<3.9.03.9.0

References

Check your stackJSON