{"cve":"CVE-2020-5216","nvd":{"published":"2020-01-23T03:15:10.683","modified":"2026-06-17T03:21:02.577","status":"Modified","description":"In Secure Headers (RubyGem secure_headers), a directive injection vulnerability is present in versions before 3.9.0, 5.2.0, and 6.3.0. If user-supplied input was passed into append/override_content_security_policy_directives, a newline could be injected leading to limited header injection. Upon seeing a newline in the header, rails will silently create a new Content-Security-Policy header with the remaining value of the original string. It will continue to create new headers for each newline. This has been fixed in 6.3.0, 5.2.0, and 3.9.0.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:L/A:N","score":5.8},"cwes":["CWE-74","CWE-113"],"references":["https://github.com/twitter/secure_headers/commit/301695706f6a70517c2a90c6ef9b32178440a2d0","https://github.com/twitter/secure_headers/security/advisories/GHSA-w978-rmpf-qmwg","https://github.com/twitter/secure_headers/commit/301695706f6a70517c2a90c6ef9b32178440a2d0","https://github.com/twitter/secure_headers/security/advisories/GHSA-w978-rmpf-qmwg"],"products":["twitter:secure_headers"],"source":"nvd","synced_at":"2026-10-19T21:01:01.339895972+00:00"},"epss":{"cve":"CVE-2020-5216","score":0.01209,"percentile":0.68405,"date":"2026-11-01"},"kev":null,"osv":[{"id":"GHSA-w978-rmpf-qmwg","url":"https://osv.dev/vulnerability/GHSA-w978-rmpf-qmwg","summary":"Limited header injection when using dynamic overrides with user input in RubyGems secure_headers","modified":"2026-07-08T05:59:41.636653462Z","packages":[{"ecosystem":"RubyGems","name":"secure_headers","purl":"pkg:gem/secure_headers","ranges":[">=6.0.0 <6.3.0"],"fixed":["6.3.0"]},{"ecosystem":"RubyGems","name":"secure_headers","purl":"pkg:gem/secure_headers","ranges":[">=5.0.0 <5.2.0"],"fixed":["5.2.0"]},{"ecosystem":"RubyGems","name":"secure_headers","purl":"pkg:gem/secure_headers","ranges":["<3.9.0"],"fixed":["3.9.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}