Critical (9.8) in pwntools project pwntools. EPSS 4.4% chance of exploitation in the next 30 days. Fixed in pwntools 4.3.1.
This affects the package pwntools before 4.3.1. The shellcraft generator for affected versions of this module are vulnerable to Server-Side Template Injection (SSTI), which can lead to remote code execution.
Severity
CVSS 3.1
9.8 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
4.4% chance of exploitation in the next 30 days; higher than 91% of CVEs (scores of 2026-10-31)