cve.bz

CVE-2020-2166

8.8 highEPSS 2.0%

High (8.8) in jenkins pipeline\. EPSS 2.0% chance of exploitation in the next 30 days. Fixed in de.taimos:pipeline-aws 1.41.

Jenkins Pipeline: AWS Steps Plugin 1.40 and earlier does not configure its YAML parser to prevent the instantiation of arbitrary types, resulting in a remote code execution vulnerability.

Severity

CVSS 3.1

8.8 high
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
2.0% chance of exploitation in the next 30 days; higher than 81% of CVEs (scores of 2026-10-31)
CWE
CWE-20
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-w598-25hm-jqx3Mavende.taimos:pipeline-aws<1.411.41

References

Check your stackJSON